Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have an issue where some of our clients attempt to login to our system using a / instead of a \ for the domain.

This ends up with them attempting to login as

computername\domain/username

Also if they forget the domain part they end up attempting to login as

computername\username

Is there a way to setup a computer so that any logins to it from remote desktop\remoteapp default to a domain username, rather than a local computer username?

Would be much simpler to have our users simply type in their username.

Even though training them to use domain\username is simple, trying to do phone support for when they did a forward slash instead of a backslash has become a nightmare.

share|improve this question
    
BOFH Solution: Sneak into their offices at night and steal all their / keys. –  SmallClanger Dec 2 '10 at 18:39

3 Answers 3

up vote 1 down vote accepted

You could educate users to use the username@domainname format instead.

If this also happens to be the users actual email address, success rates tend to be much higher.

share|improve this answer
    
If I can't find an alternative solution, this may actually be the best way to do it. They don't have an email address, but it would be a lot easier to train to use the @ symbol instead of trying to tell them they're using the wrong slash. –  Brett Allen Dec 2 '10 at 21:06
    
This has greatly solved our support problems, thank you! –  Brett Allen Feb 23 '11 at 20:47

There is a registry edit that you can make on the Server your clients are RDP/RDC into. The registry key is located at: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon The name of the key is "DefaultDomainName" Enter the name of your domain name inside this registry key and it will automatically select that when users try to login instead of selecting the Local Machine name in the "Log on to" field.

I searched around for a while for this so I hope it helps someone else.

Information on the registry key can be found at: http://technet.microsoft.com/en-us/library/cc939708.aspx

share|improve this answer

While we don't use RDS, but regular workstations, we had a similar issue where the local machine is selected by default once imaging is complete.

When we image our workstations, I have a runonce script run at the end of the OSD task sequence that hacks the registry so that the preferred domain is selected by default on the login screen, then have the machine reboot:

Set oShell = CreateObject("WScript.Shell")
oShell.RegWrite "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\DefaultDomainName", "<Domain>"

Maybe this will help you?

Note: We're still using Windows XP, so I don't think this will help if you're using Vista or 7. Sorry :S

share|improve this answer
    
Yeah this is only done on remote desktop, where a user is required to type in a username\password before they even connect. So unfortunately this doesn't work. –  Brett Allen Dec 2 '10 at 21:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.