Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed RHEL 5.3 on my desktop from Ubuntu and I'm getting some extremely slow disk reads and I haven't been able to fix the problem. I'm using a Seagate Barracuda 7200.10 ST3250820AS but only getting ~3.6 MB/sec reads. I haven't been able to set DMA using hdparm. Any suggestions on how to get better read speed out of this?

# hdparm -Tt /dev/hda
/dev/hda:
 Timing cached reads:   16380 MB in  2.00 seconds = 8209.75 MB/sec
 Timing buffered disk reads:   12 MB in  3.04 seconds =   3.94 MB/sec

I'm pretty sure the multcount is wrong as well.

# hdparm /dev/hda
    /dev/hda:
     multcount    = 16 (on)
     IO_support   =  0 (default 16-bit)
     unmaskirq    =  0 (off)
     using_dma    =  0 (off)
     keepsettings =  0 (off)
     readonly     =  0 (off)
     readahead    = 256 (on)
     geometry     = 30401/255/63, sectors = 488397168, start = 0

The current Kernel I'm on.

# uname -a
Linux novaprospekt 2.6.18-128.1.6.el5 #1 SMP Tue Mar 24 12:10:27 EDT 2009 i686 i686 i386 GNU/Linux
share|improve this question

closed as off topic by Kara Marfia Jun 6 '09 at 13:07

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
How old is the hard drive? –  KPWINC Jun 5 '09 at 21:36

3 Answers 3

One question to ask: what kind of disk controller are you on? If you're on an old, lousy ATA/33 controller that doesn't support DMA (very well), doesn't do 32-bit I/O, and so on, you're pretty limited in terms of what you can do.

share|improve this answer

using_dma = 0 (off)

This is a big problem. When you run the tests, do you notice a high cpu spike?

Try providing the output of hdparm -i /dev/hda; and see what might cause this.

share|improve this answer

Just out of curiosity, how are writes?

  dd if=/dev/zero of=fil1 bs=1M count=2000
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.