Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using the wamp server 2 for a web application. I can access files from localhost but I have it set up with access from outside via ip address which worked before I reinstalled wamp and now I'm getting a forbidden message.

Forbidden

You don't have permission to access /ClientPortal/ on this server.

Is this an apache setting I have forgottent to change?

Thanks for any help on this,

Jonesy

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There's a couple of reasons for this:

If you don't think you have an explicit exclusion such as

Order Deny,Allow Deny from All Allow from 192.168.1.0/24

It could be a simple case of missing directory index:

DirectoryIndex index.html index.htm

If you have an index.php and it's missing from the above line and DirectoryListing is denied, you'll get 403 Forbidden.

DirectoryIndex index.php index.html index.htm

By adding index.php you could fix your problem.

let us know.

Andrew

share|improve this answer
    
sorry new to this. I don't have an .htaccess file in the root directory. I tried adding one but it caused a internal server error. I want to allow all pretty much. Yeah my www directory has an index.php file as well as my subdirectory. –  iamjonesy Dec 3 '10 at 11:57
    
Try finding in httpd.conf DirectoryIndex Add index.php to the end of the list and restart Apache. –  Andrew Taylor Dec 3 '10 at 12:48
    
hi thanks to your suggestion I noticed my httpd.conf file was only allowing access to 127.0.0.1. I've changed to allow from all and it's sorted it. Thanks! –  iamjonesy Dec 3 '10 at 13:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.