Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So we've finally migrated from our old Netware environment to a virtualized OES2 system.

Everything is working with the exception of time sync. On boot the time syncs up like normal. But I very quickly GAIN lots of time. About 15 seconds per minute. The only easy resolution I've found is to run a cron job every 2 minutes to sync the time against an on premises time server. This works fairly well as far as the day to day functionality goes but its a bit aggravating.

On the same host we're running 8 Windows Server VMs that are all working fine with no additional configuration.

share|improve this question
1  
Did you install the Hyper-V Linux Integration Components? –  Chris S Dec 3 '10 at 18:30
    
Sure did Chris. –  ErnieTheGeek Dec 3 '10 at 22:16

1 Answer 1

up vote 1 down vote accepted

A couple of suggestions (based on the many many OES2 servers I have installed )

1) in boot.msg file under /boot/grub/ on the boot options line before the term showopts add the term "clock=pmtmr" without quotes - reboot server.

2) Use NTP - in the NTP config - choose a decent time source and also remove reference local undisciplined clock - make sure ntp is set to startup (chkconfig ntpd on)

Your time issues will be drastically reduced

Hope this helps

Brett

share|improve this answer
    
Sorry, should have included some of the steps I'd tried. I did both of those, configured NTP the way you're suggesting, NTP will sync once on boot, correctly update the clock, then do nothing ever again. –  ErnieTheGeek Dec 3 '10 at 18:24
    
Aha - Are you using the Linux Integration Services for Hyper-V? –  Brett Dec 3 '10 at 18:34
    
See the following link - microsoft.com/downloads/en/… –  Brett Dec 3 '10 at 18:35
    
Yup, got those installed. Synthetic NIC and everything else seems to be working fine. I tried both the original ICs and the latest 2.1 IC. –  ErnieTheGeek Dec 3 '10 at 19:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.