Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We recently upgraded our domain controllers to Windows Server 2008 R2 (Still at functional level 2003).

I went to make a change to one of our login scripts in the SYSVOL\{domain}\scripts\ directory, despite the account I was logged in with having Enterprise Administrator and Domain Administrator permissions it will not let me edit the scripts or add new ones.

I've tried googling around to see if I can find any information but so far I'm turning up dry. Does anyone have any idea how I could fix this?

share|improve this question
1  
what happens when you go through netlogon? its probably share permissions issues. run dcdiag /test:netlogons n –  tony roth Dec 3 '10 at 21:50
    
Why not use GPMC for assigning scripts rather then assigning them directly on the user account? –  joeqwerty Dec 4 '10 at 0:07
    
I do assign them through GPMC, this is the creation and editing of the actual scripts. –  TrueDuality Dec 6 '10 at 13:22

2 Answers 2

up vote 1 down vote accepted

Where you logged in from the local machine? Are you sure you aren't having problems with the UAC? By default your administrative privileges will be filtered away for you protection. Try accessing the folder from a remote machine while logged in as an account with admin privileges.

share|improve this answer
    
I was remoted into the machine, while not exactly the same as logging in at a console, I wasn't manipulating the file through a network share. –  TrueDuality Dec 6 '10 at 13:24
    
It was indeed UAC. That's annoying as hell. Thanks! –  TrueDuality Dec 6 '10 at 13:54

This is a UAC issue; many administrators are disabling UAC because of filesystem access issues like this (though disabling UAC is not recommended).

The fastest way to resolve this particular situation, in my experience, is to launch notepad with administrative elevation, and then open the file to be changed from within notepad (or substitute your preferred editor in place of notepad).

share|improve this answer
    
I have tried editing in notepad using elevated privileges. I have not tried disabling UAC however. –  TrueDuality Dec 6 '10 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.