Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i want to remove squid package from my Linux box kernel 2.6

root@t:~/devel # rpm -i squid-2.6.STABLE18-5.endian6.i586.rpm --nodeps
        package squid-2.6.STABLE18-5.endian6 is already installed
root@t:~/devel # rpm -e squid-2.6.STABLE18-5.endian6.i586.rpm --nodeps
error: package squid-2.6.STABLE18-5.endian6.i586.rpm is not installed

whats wrong?

share|improve this question
    
The version of the Linux kernel is largely irrelevant to this kind of problem. It'd be more helpful to know what distribution you're running. (The commercial Endian Firewall package?) –  mattdm Dec 5 '10 at 18:16
add comment

2 Answers

You should not use the package file name when removing a package. You should use the package name. So, you can try:

# rpm -e squid-2.6.STABLE18-5.endian6

You can confirm the correct name by listing all the packages using:

# rpm -qa | grep squid

If there is an error when trying to install the package, you can try (add --force):

# rpm -i --force squid-2.6.STABLE18-5.endian6.i586.rpm --nodeps
share|improve this answer
    
thank you, but its give me same error. rpm -qa |grep squid -> squid-2.6.STABLE18-5.endian6 –  haw3d Dec 4 '10 at 11:29
    
@haw3d: I updated my answer. Have another look. –  Khaled Dec 4 '10 at 11:45
    
installed but the same error –  haw3d Dec 4 '10 at 11:54
    
@haw3d: Eventually, are you trying to install or remove this package? –  Khaled Dec 4 '10 at 11:56
    
i want to uninstall these packet, actually i want to install this package by source –  haw3d Dec 4 '10 at 12:21
show 1 more comment
up vote 0 down vote accepted

i can found a way to uninstall:

rpm -ev squid

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.