Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Fedora 10 and have php 5.2.9, Unfortunately I saw that '--disable-xmlreader' (from phpinfo() ) was passed to the RPM file when PHP was intalled. How can I enable xmlreader for a pre-existing php install?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

1.wget http://dev.centos.org/centos/4/testing/i386/RPMS/php-xml-5.1.6-3.el4s1.7.i386.rpm 2. yum --enablerepo=centosplus install php-xml* 3. Restart apache
4. php -i |grep xmlreader and paste result here if stil not enable

share|improve this answer
    
When I ran the second command it said Error getting repository data for centosplus, repository not found –  jax Dec 4 '10 at 12:01
    
I also tried yum install php-xml, which worked and I have xmlreadher.ini and xmlwriter.ini in /etc/php.d but they don't seem to do anything. xmlreader.ini contains extension=xmlreader.so and from phpinfo() I can see the file it parsed. There is still no xmlreader support though. –  jax Dec 4 '10 at 12:03
    
I just erased php-xml and reinstalled and it works :) –  jax Dec 4 '10 at 12:12
    
Good ;) i hope my tutorial help you . –  ntrance Dec 4 '10 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.