Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have CSF v5.12 (generic) installed on my CentOS 4.4 server, and am trying to use the tempban/tempdeny feature to temporary add a firewall block to a specific IP. (I am building a PHP script which needs to block abusive users for an hour)

The command I am running is:

[root@domfe01 csf]# /usr/sbin/csf --tempdeny 175.107.146.57 10
DROP  all opt -- in !lo out *  175.107.146.57  -> 0.0.0.0/0  
csf: 175.107.146.57 blocked on port * for 10 seconds inbound

However, more than 10 seconds later and the IP is still blocked.

I don't really know what to do next, as CSF appears to function correctly.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It might be best to ask Chirpy (the author) himself. I ran into some quirkeness some time ago and he was an excellent help. visit ConfigServer and write a comment there for a quick response.

your command does appear correctly -

you could however always write a script to remove from the csf.deny any item that is over 1 hour old instead

share|improve this answer
    
Thanks, I've posted on their forums. Hopefully I'll get a solution either here or there soon. –  Valorin Dec 5 '10 at 22:31
    
One of our admin's fixed it for me. LFP(?) wasn't running as a service, as a perl module was missing. The temp ban stuff works fine now. –  Valorin Dec 7 '10 at 2:06
    
It was probably LFD, not LFP. It stands for Login Failure Daemon, and is the daemon that runs a bunch of CSF's features. –  devicenull Dec 21 '10 at 2:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.