Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VM host with a Gigabit network connection hosting about 5 guest OS's on a bridged virtual network.

The problem is that the VM Host (including all guest VM's) is only able to transfer at about 100K/s on the network despite there being ABSOLUTELY NO network traffic whatsoever. The odd thing is that this only happens in upstream transfers. Downstream transfers are still normal.

Any ideas as to the cause?

UPDATE

I have narrowed the culprit to being the 100Mb HALF DUPLEX network connection on the VM host. This is causing an effect of network transfers only being fast in one direction.

share|improve this question

4 Answers 4

It sounds like you have a single NIC for five VMs. If you have more than one NIC in the system, you might want to think about bonding the NICs together to get more bandwidth for the five VMs. If you only have one, you might want to look into buying a dual or quad-port NIC, bonding those interfaces, and bridge the VMs out that way.

share|improve this answer
    
I have considered utilizing an additional NIC to get more traffic, but what is odd is that there is no traffic going on at all in any of the guests or hosts. –  Matias Nino Jun 6 '09 at 2:37
    
It is one nic, but it's also gig-e, so the chances of saturation from 5 VM's is somewhat low. Have you ruled out the host having transfer problems? –  JohnW Jun 6 '09 at 17:11
    
The host has no transfer issues whatsoever. I reduced the # of running VM's to one and it still cannot transfer above 200K/s either to the internet or the LAN. –  Matias Nino Jun 7 '09 at 20:23

Not this is not normal. Make sure that the driver is up to date then verify that you do not have a link speed or duplex mismatch on the switch.

share|improve this answer
    
Drivers are up to date, but no change in VM LAN speed. Not sure exactly where to check for link speed or duplex mismatches. –  Matias Nino Jun 7 '09 at 22:52

What about the speed from the host itself? (ruling out hypervisor problems)

Have you tried peer to peer? (ruling out switch/router problems)

Have you tried a different network cable or NIC? (ruling out hardware problems)

share|improve this answer
    
The VM Hosts's speed and network transfers all checks out fine on the network to all places. It is only the guest VM's that seem to have their speeds severely capped. Not sure what you mean about peer to peer. –  Matias Nino Jun 7 '09 at 22:48
    
peer to peer just means that you connect two machines without any switches/routers/hubs/other, just the cable. –  Hofa Jun 8 '09 at 13:14
up vote 0 down vote accepted

I finally discovered the culprit: The physical network switch (supposed to be 1Gbps) was auto-negotiating to 100Mbps HALF DUPLEX(!!!), which was in turn causing all upstream from the server (including the VM's) to be capped at < 1Mbps.

I mistakingly though the host was unaffected because my test on the host only included a DOWN-transfer and not UP. (doh! sorry!)

I guess this question should now be renamed to: Why is my switch auto-negotiating some ports to 100Mbps HALF DUPLEX when it should be auto-negotiating all ports to 1Gbps FULL DUPLEX! It's an old switch so I'm thinking some ports on it just can't crank it up to FULL DUPLEX anymore.

Lesson to be learned: When you are about ready to kill someone (or yourself), chances are it's a hardware problem.

share|improve this answer
    
Check you cables. If some of the pins are bad it won't be able to negotiate to FD. Could also be drivers -- the auto-negotiation is not as 'standard' as we would like -- sometime you have to hard-set both sides. –  Peter Jun 8 '09 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.