Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am wondering if anyone has been able to create multiple VNC servers on the same network. I have conquered 2, but once I try to do 6 at the same time, it seems impossible. I was told to try port number 5910, 5920, and 5930 as well. We would like to use tightvnc because of the capabilities of accessing it via web browser.

Thanks in advance

share|improve this question
There is nothing that prevents you from having seven million VNC servers on the same network. The advice someone gave you about using separate ports implies that you mean multiple VNC servers on the same machine. (Perhaps on a firewall system providing port forwarding to internal systems.) Can you describe the problem more specifically? – mattdm Dec 6 '10 at 21:36
basically I just don't know what ports to put in the server itself, it asks for the main port number and the http number. We have 6 computers on the same static public ip address. We need to be able to access them from outside the network. – Joe Dec 6 '10 at 21:42
Im reading about putting XXX.XXX.XXX.XXX:5900+N for the web address. Can anyone confirm how to use that? I assume it is to use multiple vnc connections at one network location but changing the N will select what pc?... – Joe Dec 6 '10 at 21:51
VNC allows multiple connections. If you set it for the +N port, it's when someone is already connected to port N. – Bart Silverstrim Dec 7 '10 at 11:20

You install VNC server on each machine, no changes.

On your firewall/NAT router/gateway you assign the port to forward to the IP address internally. I.e., if you have an eternal IP address of aaa.bbb.ccc.ddd then you assign port 5900 to go to internal machine 1 on aaa.bbb.ccc.ddd, then 5901 to go to machine 2 on aaa.bbb.ccc.ddd, then 5902 to machine 3 on aaa.bbb.ccc.ddd, etc.

You don't need a 1:1 mapping of "this port on the external interface goes to the exact same port on this machine internally." I had a NAT gateway that had a port in the hundreds region that forwarded to port 22 on my internal 192.168.x.x machine at home.

I don't know what exactly you're trying to do, but I'd add a note that unless you're using a special version of VNC you may be running without any encryption, which you might want to be careful to open to the "public" network.

It sounds like what you may mean by getting two to work is that you forwarded one port to a machine's VNC port and you forwarded the web server version to another machine. You need to forget about 1:1 mapping of ports or you won't get anywhere with adding more servers.

I would strongly suggest that if you're not encrypting VNC connections you should look at setting up a firewall that allows VPN connections and let people connect to your internal network via VPN. That eliminates port forwarding altogether and also encrypts your connection, allowing your network far more security as this setup we're describing opens your internal network to potential abuse.

share|improve this answer
Oh okay, We were trying to set the ports on the vnc server machines as well. We have a cisco ASA, with two working VNC's setup. I can probably just copy those rules and paste them in and just change the ip address/port and be good to go. I will try that out and see how it goes. Thanks for your help – Joe Dec 6 '10 at 22:15
So even with tight vnc wanting to put in the main port as like 700 something, I should just leave that there? – Joe Dec 6 '10 at 22:17
Leave the port on the actual computers the default. Don't change it or you're adding administrative overhead. – Bart Silverstrim Dec 7 '10 at 11:15
All your port changes should be done at the gateway/firewall. Your external IP will have port A forwarded to internal IP 1, default VNC port. Port B will be forwarded to internal IP 2, default VNC port. Port C will be forwarded to internal IP 3, default VNC port. – Bart Silverstrim Dec 7 '10 at 11:16
Okay, I have got all of them working so far. Thanks for all the help. The only issue now is getting the HTTP part of it done to be able to access them from the internet browser. Any suggestions as how to go about that? – Joe Dec 7 '10 at 14:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.