Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Today I get an alert mail from linode.com "Your Linode, Randy, has exceeded the notification threshold (1000) for disk io rate by averaging 1571.81 for the last 2 hours.".

Last time I get alert like that is several month ago, I keeping get alerts, but at the same time my website network traffic never grow. I try everything, but can not location the problem. Finally, I guess the growing log file size is the problem. I use cronolog cut log file, and problem resolved.

Now,I/O rate chart shows I/O rate is keeping growing too, how to I location problem? Is there anything can help me?

My server is Ubuntu 8.04.4 LTS/apache/php/mysql at linode.com.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

You can determine which process is thrashing your disk using the iotop package. http://ubuntuforums.org/showthread.php?t=876738

Also, you can change the I/O rate alert threshold in the Settings tab of the Linode web interface.

share|improve this answer
    
Can I determine which file is write or read? –  Tinyfool Dec 7 '10 at 23:59
    
Once you see which process is writing, you can use 'sudo lsof | grep process_name' to see which files it has open. –  slillibri Dec 14 '10 at 23:05

1st,you may be find the problem , mysql or apache
using vmstat iostat

2nd, if problem from apache , you can using nginx +fastcgi to replace apache it is a light web server, better than apache

 if problem  from mysql  ,you can modify  my.cnf   

3rd if problem from other app? please paste your log file

share|improve this answer
    
point is how to use vmstat or iostat find problem from what app? I just can see some global info, not info about a app. –  Tinyfool Dec 7 '10 at 13:03

Try vmstat and see if there's much bi/bo. I thought it is caused by swap thrashing, due to the small physical memory of your Linode.

share|improve this answer
    
bi=2,bo =4. I don't think so, because seems memory is never run out. –  Tinyfool Dec 7 '10 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.