Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed CentOS 5.5 servern with a KDE desktop. Everything seems to be functioning okay but I keep getting this error when I turn on my computer (the log while starting up). I have installed apache, mysql, phpmyadmin, dovecot and using a tutorial I edited fstab from:

Original FSTAB file

/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

Modified FSTAB file in use (according to the tutorial I used)

/dev/VolGroup00/LogVol00 /                       ext3    defaults,usrquota,grpquota        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

All processes start okay but the parameter Enabling local file system quotas returns failed. What are the implications of this? How can I correct this error?

When I type quotacheck -a in the terminal it returns

quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't save quota settings.

quotacheck: Cannot remount filesystem mounted on / read-only so counted values might not be right.

Please stop all programs writing to filesystem or use -m flag to force checking
share|improve this question
    
Does the file /aquota.user exist? –  MadHatter Dec 7 '10 at 16:20
    
yes it does exist –  rzlines Dec 7 '10 at 16:25

1 Answer 1

Do you have /aquota.user and /quoata.group files? Run quotacheck -cug / to create them if you haven't.

share|improve this answer
    
they both exist, do i still run the command? –  rzlines Dec 7 '10 at 16:33
    
Yeah; it'll properly initialize the file. Boot into single user mode to run it, so nothing else is going on. –  mattdm Dec 7 '10 at 16:39
    
should i run it as root? –  rzlines Dec 7 '10 at 16:41
1  
Yes. (That's implied by single-user mode, btw.) –  mattdm Dec 7 '10 at 16:44
    
I did that n I get the error bad number of arguments. Utility for checking and reparing quota files. quotacheck [-gucfinvdmMR] [-F <quotaformat>] filesystem|-a –  rzlines Dec 7 '10 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.