Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running multiple wordpress blogs on the following setup:

Server 2008 R2; IIS 7.5; PHP 5.3.3; MySQL 5.0.7;

I upgraded my wordpress install from 2.9.2 to 3.0.2 (on 2 different sites) today and the upgrade went fine. I can serve .php pages without errors, log into the admin system etc. I can browse my blog by going directly to mywebsite.com/index.php, but when I try to go to mywebsite.com (without the index.php) I get he below 500 error.

I reset IIS, removed and re-attached the default document, but I am running out of ideas.

Please if anyone has a solution for this that would be great.

This is the 500 error I am getting:

Error Summary
HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.

Detailed Error Information
Module FastCgiModule
Notification ExecuteRequestHandler
Handler PHP FastCGI
Error Code 0x00000000
Requested URL http://mywebsite.com:80/index.php
Physical Path D:\mywebsite.com\index.php
Logon Method Anonymous
Logon User Anonymous

Thanks

Stephan

share|improve this question
    
Looks like it might have something to do with permalink redirects, I am using IIRF to do the redirects and not of them are working anymore anyone could see how that is related? –  Maniac13 Dec 9 '10 at 22:07
add comment

2 Answers

Open your PHP.ini and look for the "error_log" value. Make sure it points to a file where the IIS worker process can write. Also check the "error_reporting" value and make sure it includes "E_ALL".

After that, open the file pointed at by the "error_log" value: it should contain more information about what broke.

share|improve this answer
add comment

Open IIS -> Selct Your web site -> Under IIS Section

Error Pages -> 500 -> Edit Feature Settings -> "Detailed Erros"

This how you will be able to see exact error and that might help you to resolve your isuse.

Best of Luck :)

share|improve this answer
    
Thanks Ankur, but this only gives me the same error as the one above –  Maniac13 Dec 9 '10 at 22:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.