Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VPN connection to my remote Win08 server running Windows Firewall w/ Adv. Sec. I open all ports to a handful of specific IPs which gives me ability to connect with Remote Desktop Connection as well as access to the file system (mapping network drives).

Now i'm trying to configure access to the sql server. Working from my local MSSMS I can see the remote Database Engine in the 'Browse for Servers | Network Servers' dialog. But I can't actually establish a connection (the standard 'cannot connect to...' error dialog pasted below) until i turn off the 'Private Profile' of the firewall.

So the firewall rule that grants access to File Sharing and Remote Desktop Connection is not granting access to the SQL Server. Where do I look for additional config options?

TITLE: Connect to Server

Cannot connect to myBoxName.

------------------------------ ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 1326)

share|improve this question

migrated from stackoverflow.com Dec 8 '10 at 1:19

This question came from our site for professional and enthusiast programmers.

    
Did you create a rule to allow incoming connections on Sql port 1433? –  tucaz Dec 6 '10 at 12:25
    
io using the named pipes provider, you could try to configure the client to only use TCP connections. –  Lieven Keersmaekers Dec 6 '10 at 12:26
    
The existing rule is set to allow any port, program, protocol ...checking that TCP connection angle now. –  justSteve Dec 6 '10 at 12:57
    
Checked that TCP connection angle - no joy. The error message changed to reflect the TCP/IP failure. –  justSteve Dec 6 '10 at 13:08

2 Answers 2

This KB shows all the ports you need to allow in 2k8

http://support.microsoft.com/kb/968872

share|improve this answer
up vote 0 down vote accepted

Strangeness on the part of the firewall. What wasn't working when i started the question now works. I tried executing the script referenced by the KB article without any change. Then re-defined a new rule that opened all ports, protocols, profiles, and programs - essentially duplicating the pre-existing rule. I found i had access. I disabled the new rule and still had access. [shrugging]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.