Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have done a reverse proxy with an Apache in the background (on the same server). All works great but I can't open one page.

I get the error "The request or reply is too large."

In my cache.log contains:

2010/12/09 15:28:29| WARNING: http.c:971: HTTP header too large
2010/12/09 15:29:03| ctx: enter level  0: 'http://server/admin/cms/nav'
2010/12/09 15:29:03| httpProcessReplyHeader: Too large reply header
2010/12/09 15:29:03| ctx: exit level  0

In my squid.conf i disabled the limitations of the request and reply header, without success:

reply_body_max_size 0 allow all
request_body_max_size 0

Does someone know why that don't work?

Thank you very much.

Squid Version:

Squid Cache: Version 2.7.STABLE3
configure options:  '--prefix=/usr' '--exec_prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--sysconfdir=/etc/squid' '--localstatedir=/var/spool/squid' '--datadir=/usr/share/squid' '--enable-async-io' '--with-pthreads' '--enable-storeio=ufs,aufs,coss,diskd,null' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-epoll' '--enable-removal-policies=lru,heap' '--enable-snmp' '--enable-delay-pools' '--enable-htcp' '--enable-cache-digests' '--enable-underscores' '--enable-referer-log' '--enable-useragent-log' '--enable-auth=basic,digest,ntlm,negotiate' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--enable-carp' '--enable-follow-x-forwarded-for' '--with-large-files' '--with-maxfd=65536' 'amd64-debian-linux' 'build_alias=amd64-debian-linux' 'host_alias=amd64-debian-linux' 'target_alias=amd64-debian-linux' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=' 'CPPFLAGS='
share|improve this question
    
I updated to Version 3.1 (Debian Backports), now it's working. –  Ueli Dec 13 '10 at 6:30

1 Answer 1

The main problem is large reply header, so you can increase it. Default value is 20KB so you can increase it. For example by this command

reply_header_max_size 200 KB
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.