Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed SNORT and ACID/BASE following this step by step tutorial: https://help.ubuntu.com/community/SnortIDS on a remote Debian host over SSH. The main difference being that I have already setup a firewall that fillers all incoming traffic except for SSH, HTTPS and loopback.

Now when I try to access https ://domain.xx/acidbase/base_db_setup.php , i.e. acidbase's front end in the final configuration step I get the following error:
403 FORBIDDEN
You don't have permission to access /acidbase/base_db_setup.php on this server.

I have already run this command:
sudo sed -i "s#allow\ from\ 127.0.0.0/255.0.0.0#allow\ from\ 127.0.0.0/255.0.0.0\ 10.10.1.10/255.255.255.0 my-vpn-gateway.xx#" /etc/acidbase/apache.conf
and restarted Apache.

I also tried to access the URL from within my SSH session via Lynx web browser but whenever I type: https ://localhost/ it tells me:
Unable to make secure connection to remote host.
However when I type: https ://mydomain.xx/ it works. So maybe I also have some bug in my Apache configuration.

The remote host is running an Apache 2.2 web server, and I disabled the VirtualHost on port 80 and left only the one for port 443.

Any help would be greatly appreciated.

Thank you

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Finally discovered the problem. It was actually an Apache configuration problem. All I had to do is add back:
NameVirtualHost *:80
Listen 80

To my ports.conf file and restart Apache. I had initially removed them before setting up the Firewall to restrict the access to HTTPS only. After this I managed to access http://localhost from the Lynx web browser within my SSH session.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.