Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows 2003 Server on which we have installed Microsoft's Services for UNIX, and we have mounted a few NFS shares that contain shared resources that we need to access from this box. When I log in to this server with remote desktop, I am able to browse the contents of the NFS shares and everything works fine.

However, one use case that we have is that we need to access this server using SSH, and still be able to access the NFS shares. We are running the Cygwin SSH daemon to provide SSH access to the server, but for some reason when we log in to the Windows 2003 server using SSH we can no longer access the NFS shares.

To demonstrate, here is the output of the 'mount' command, first from a Cygwin shell when logged in with remote desktop:

$ mount
C:/cygwin/bin on /usr/bin type ntfs (binary,auto)
C:/cygwin/lib on /usr/lib type ntfs (binary,auto)
C:/cygwin on / type ntfs (binary,auto)
C: on /cygdrive/c type ntfs (binary,posix=0,user,noumount,auto)
O: on /cygdrive/o type nfs (binary,posix=0,user,noumount,auto)
P: on /cygdrive/p type nfs (binary,posix=0,user,noumount,auto)
Z: on /cygdrive/z type nfs (binary,posix=0,user,noumount,auto)

And now, the same 'mount' command when logged in with SSH:

$ mount
C:/cygwin/bin on /usr/bin type ntfs (binary,auto)
C:/cygwin/lib on /usr/lib type ntfs (binary,auto)
C:/cygwin on / type ntfs (binary,auto)
C: on /cygdrive/c type ntfs (binary,posix=0,user,noumount,auto)

Notice the missing O: P: and Z: NFS shares in the latter.

Can anyone tell me why I am unable to see these NFS shares when logged in with SSH?

Thanks!

share|improve this question
    
Are you SSHing in as the same user that you're logged on locally with? Does running id give the same output on both? I'm betting this is permissions-related... –  Andy Smith Dec 19 '10 at 21:38

1 Answer 1

gpedit.msc -> Computer Configuration -> Windows Settings -> Scripts (Startup/Shutdown) add script batchfile.bat with content:
@echo off
sleep 10
mount \192.168.1.1\folder o:
And then you will see mounted discs in ssh.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.