Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install a program called phraseanet. I ran the ./configure command and run into this error:

configure: error: Cannot find php-config. Please use --with-php-config=PATH

I am using Ubuntu 10.04, Apache 2, PHP5 and Mysql 5

Does anyone know where I can find the php-config? I can't find that file....

share|improve this question

2 Answers 2

To use php-config you will need to have the PHP development package installed, in Ubuntu you can install the PHP5 development package using:

sudo apt-get install php5-dev 

After installing the php5-dev package, (on my Ubuntu installation) php-config can be found in:

share|improve this answer
Note that the right php-config might be /usr/bin/php-config54 or /usr/bin/php-config55, etc. according to your PHP verison. – Martin Apr 8 '14 at 10:30

that is a script that display the configuration from the ink file - see if you can not install it with apt try to download the source code from the php site.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.