Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a colocated Mac OS X 10.6 server, and I need to create a new user on the box. (The existing users were created by me when the box was on my desk.) I'm able to connect to the machine using SSH and also using the Server Admin utility. However, user management appears to require the Server Preferences utility. When I try to connect with Server Preferences, I get this error:

Unable to set node credentials for /LDAPv3/127.0.0.1 with the record name [FDQN]$.

There may be a problem with the Open Directory service.

(N.B. I've obscured the actual server name; where it says [FDQN] above, the actual error has the complete name of the server.)

In the server logs, which I can see using Server Admin, I see

Dec 10 11:31:05 eiffel servermgrd[63]: servermgr_accounts: got error 5203 trying to auth to local LDAP node

(N.B. eiffel is the hostname.) I think this is the relevant line; Jabber is flapping for some reason (different problem) and smothering the logs with its attempts to start up.

I'm not familiar with Open Directory, and I don't really want to have to be; I just want to administer my server, in particular to create a new unix user on the box so they can connect via SSH. Thanks for any pointers.

(ETA: My research suggests that VNC would solve this problem. Unfortunately, I need access to Server Preferences to allow VNC access, so that's a Chicken and egg problem. (See what I did there?) Setting up an SSH tunnel sounds like a great idea, but I need a bit more fine-grained advice (which ports on each end?) to put that into practice.)

ETA, 12/16: I'm able to add a new user with the Workgroup Manager utility, which is part of the server tools package. (I suspect I have it on my laptop and not my desktop, which is why I didn't find it sooner.) Even though the urgency is gone, I'm leaving the question open because I still can't connect with Server Preferences.

share|improve this question
    
Somebody finally forked Chicken of the VNC, eh? About time. +1 for making me aware of this fact :). –  VxJasonxV Dec 20 '10 at 10:20
add comment

2 Answers

up vote 4 down vote accepted
+25

You could enable Apple Remote Desktop via the command line

As for the SSH tunnel, the main port is TCP 311

ie: ssh -N remoteUsername@remoteServer -L localPort/connectToHost/remotePort

for

ssh -N remoteUsername@remoteServer -L 311/localhost/311

share|improve this answer
    
Thanks, this is promising. I enabled Apple Remote Desktop; however, even with both ports 311 and 389 tunnelled, Chicken reports: "Please configure Apple Remote Desktop to allow VNC Viewers to control the screen. Unknown authType 30,35". I also tried tunnelling port 5900 and connecting to localhost instead. Server Preferences is giving the same error as well. –  pjmorse Dec 16 '10 at 15:34
    
Try using Apple's Screen Sharing program (/System/Library/CoreServices/Screen\ Sharing.app) and see if that will let you connect –  tegbains Dec 17 '10 at 3:14
1  
Apple's Screen Sharing utility is a winner. Thanks. –  pjmorse Dec 22 '10 at 15:17
add comment

Did you try to connect with your System Administrator/root account? Normally you should have created a Directory Administrator when first setting up Open Directory (likely named diradmin). You need to connect with this credentials.

Also, make sure you can connect to the LDAP port on the server (389) and if it is blocked by the firewall (as it should be), try to create an SSH tunnel or setup the VPN service and connect with this method.

share|improve this answer
    
I'm sorry, this might actually contain a useful answer, but it's full of concepts which are unfamiliar to me. Yes, I tried to connect with my system administrator user. I did not set up a Directory Administrator, or at least I don't recall doing so; we're not using the Open Directory. I just need to connect Server Preferences to the damn box, not run an LDAP installation. –  pjmorse Dec 13 '10 at 22:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.