Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

It would seem that when I attempt to access my Plesk admin page this is unavailable. After doing some cursory checks I discovered that the server was not listening for incoming requests on port 8443 (verified remotely via telnet).

I therefore assumed that the service was not running and therefore issued the following command via SSH under the root account:

/etc/init.d/psa start

This results in the following output:

Starting xinetd service... done
Starting named service... done
Starting mysqld service... done
Starting postgresql service... done
Starting psa-spamassassin service... done
Plesk: Starting Mail Server... already started
Starting Plesk... failed
Starting drwebd service... not installed

As a possibly related issue, today I experience a server outage for reasons yet unknown. As part of the investigation into this I used Plesk to reboot the server. This action completed successfully and was the last action I performed in Plesk. Since the reboot I can access all services other than plesk itself.

Having never encountered this issue before, and also being something of a newbie when it comes to administering a Linux based server, I have no idea where to go next? Is there are log file I can check for service start errors? Is the solution staring me in the face? Or maybe something else.

Thanks in advance

EDIT Something else that may or may not be relevant:

After rebooting, and before attempting to access Plesk again I installed sysstat with yum in order to be able to use iostat. Other than that no other changes have been made to the server.


The last entry in the /var/log/sw-cp-server/error_log file is

2010-12-10 18:35:34: (log.c.75) server started
2010-12-10 18:35:34: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)

If I attempt to start Plesk with the command I mentioned earlier 2 new entries, the same as the one above, are added to the error log. I have found some reference to this error log entry and these relate to an updated version of SSL breaking plesk, however I have not (to my knowledge) updated SSL (unless the install of sysstat did this in the background??)

Output from df -h is:

Filesystem            Size  Used Avail Use% Mounted on
/dev/md1              9.2G  5.2G  3.7G  59% /
/dev/md5              9.4G  2.2G  7.2G  23% /usr
/dev/md6              446G  5.2G  440G   2% /var
none                  2.0G  8.0K  2.0G   1% /tmp


As the errors in the log seem to point to the issue that whose resolution is detailed here:


I have followed the guidelines in that KB, with the following outputs:

[root@s15421692 dumping]# wget -c http://kb.parallels.com/Attachments/12669/Attachments/sw-cp-server-1.0-6.201004011105.centos5.i386.rpm
--2010-12-10 19:05:53--  http://kb.parallels.com/Attachments/12669/Attachments/sw-cp-server-1.0-6.201004011105.centos5.i386.rpm
Resolving kb.parallels.com...
Connecting to kb.parallels.com||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 429868 (420K) [application/x-redhat-package-manager]
Saving to: `sw-cp-server-1.0-6.201004011105.centos5.i386.rpm'

100%[======================================>] 429,868      509K/s   in 0.8s

2010-12-10 19:05:54 (509 KB/s) - `sw-cp-server-1.0-6.201004011105.centos5.i386.rpm' saved [429868/429868]

[root@s15421692 dumping]# rpm -Uhv sw-cp-server-1.0-6.201004011105.centos5.i386.rpm
error: Failed dependencies:
        libbz2.so.1 is needed by sw-cp-server-1.0-6.201004011105.centos5.i386
        libcrypto.so.6 is needed by sw-cp-server-1.0-6.201004011105.centos5.i386
        libpcre.so.0 is needed by sw-cp-server-1.0-6.201004011105.centos5.i386
        libssl.so.6 is needed by sw-cp-server-1.0-6.201004011105.centos5.i386

[root@s15421692 dumping]# yum install sw-cp-server-1.0-6.201004011105.centos5.i386.rpm
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: www6.atomicorp.com
addons                                                   |  951 B     00:00
atomic                                                   | 1.9 kB     00:00
atomic/primary_db                                        | 412 kB     00:00
base                                                     | 2.1 kB     00:00
extras                                                   | 2.1 kB     00:00
updates                                                  | 1.9 kB     00:00
Setting up Install Process
Examining sw-cp-server-1.0-6.201004011105.centos5.i386.rpm: sw-cp-server-1.0-6.201004011105.centos5.i386
Marking sw-cp-server-1.0-6.201004011105.centos5.i386.rpm as an update to sw-cp-server-1.0-3.200811141432.centos5.x86_64
Resolving Dependencies
--> Running transaction check
---> Package sw-cp-server.i386 0:1.0-6.201004011105.centos5 set to be updated
--> Processing Dependency: libbz2.so.1 for package: sw-cp-server
--> Processing Dependency: libcrypto.so.6 for package: sw-cp-server
--> Processing Dependency: libpcre.so.0 for package: sw-cp-server
--> Processing Dependency: libssl.so.6 for package: sw-cp-server
--> Running transaction check
---> Package bzip2-libs.i386 0:1.0.3-6.el5_5 set to be updated
---> Package bzip2-libs.x86_64 0:1.0.3-6.el5_5 set to be updated
---> Package openssl.i686 0:0.9.8e-12.el5_4.6 set to be updated
---> Package pcre.i386 0:6.6-2.el5_1.7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

 Package          Arch       Version                          Repository   Size
 sw-cp-server     i386       1.0-6.201004011105.centos5       /sw-cp-server-1.0-6.201004011105.centos5.i386
                                                                          1.2 M
Installing for dependencies:
 bzip2-libs       i386       1.0.3-6.el5_5                    updates      37 k
 openssl          i686       0.9.8e-12.el5_4.6                base        1.4 M
 pcre             i386       6.6-2.el5_1.7                    base        112 k
Updating for dependencies:
 bzip2-libs       x86_64     1.0.3-6.el5_5                    updates      35 k

Transaction Summary
Install      3 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total size: 2.8 M
Total download size: 1.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): bzip2-libs-1.0.3-6.el5_5.x86_64.rpm               |  35 kB     00:00
(2/4): bzip2-libs-1.0.3-6.el5_5.i386.rpm                 |  37 kB     00:00
(3/4): pcre-6.6-2.el5_1.7.i386.rpm                       | 112 kB     00:00
(4/4): openssl-0.9.8e-12.el5_4.6.i686.rpm                | 1.4 MB     00:00
Total                                           6.0 MB/s | 1.6 MB     00:00

Package sw-cp-server-1.0-6.201004011105.centos5.i386.rpm is not signed
[root@s15421692 dumping]# /etc/init.d/psa start
Starting xinetd service...                                           done
Starting named service...                                            done
Starting mysqld service...                                           done
Starting postgresql service...                                       done
Starting psa-spamassassin service...                                 done
Plesk: Starting Mail Server... already started
Starting Plesk...                                                    failed
Starting drwebd service...                                           not installed
share|improve this question

1 Answer 1

up vote 1 down vote accepted

I'm going to put my money on the partition containing /var being full. Check df -h and see if that's the case. There is a log file at (from memory so use tab complete if I'm slightly off) /var/log/sw-cp-server/error_log

share|improve this answer
I have edited my question to include data from the error log file (your path was spot on BTW) and also output from the df command. I have to admit that I don't know how to interpret that information but if I am reading it correctly there is loads of space available. –  MrEyes Dec 10 '10 at 23:42
I think yum configured to only install signed packages. Rather than modify yum settings, try: rpm -Uvh sw-cp-server-1.0-6.201004011105.centos5.i386.rpm –  James L Dec 12 '10 at 13:19
I tried that command, but I got a number of failed depenedcies (libbz2.so.1, libcrypto.so.6, libpcre.so.0, libssl.so.6) so I have run "yum update openssl" and "yum update pcre" - this leaves me with one missing dependency : libbz2.so.1 - However I can't find the package name needed to update/install this with Yum. Any ideas as to what it might be? –  MrEyes Dec 16 '10 at 14:07
Found it (I hope) - I ran "yum install bzip2-devel" and then ran the rpm command you gave above. I can now access Plesk and all is well in the world. Many many thanks for your help –  MrEyes Dec 16 '10 at 14:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.