Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem deploying Django app using Gunicorn and Supervisor. While I can make Gunicorn serving my app (by setting proper PYTHONPATH and running apropriate command, the one from supervisord config) I can't make supervisor to run it. It just won't see my app. I don't know how to make sure if the config file is ok.

Here's what supervisorctl says:

# supervisorctl start myapp_live
myapp_live: ERROR (no such process)

I'm running it on Ubuntu 10.04 with following config:

File /home/myapp/live/deploy/supervisord_live.ini:

command=/usr/local/bin/gunicorn_django --log-file /home/myapp/logs/gunicorn_live.log --log-level info --workers 2 -t 120 -b -p deploy/ webapp/

In /etc/supervisor/supervisord.conf, at the end of the file, there is:

files = /etc/supervisor/conf.d/*.conf

and here's a symlink to my config file:

# ls -la /etc/supervisor/conf.d
lrwxrwxrwx 1 root root   48 Dec  4 18:02 myapp-live.conf -> /home/myapp/live/deploy/supervisord_live.ini

everything looks fine for me but supervisorctl just keep saying myapp_live: ERROR (no such process). Any solution for this?

share|improve this question
I was scratching my head with the same problem; my configuration files weren't being loaded when I ran reread or update. It turned out I had saved my config files as instead of foo.conf so they weren't being identified. – Timmy O'Mahony Sep 11 '14 at 15:49

11 Answers 11

up vote 24 down vote accepted

I had the same issue, a

sudo service supervisord reload

did the trick, though I don't know if that is the answer to your question.

share|improve this answer
I stopped and then started supervisor some time ago and it worked. Don't know if reload would work (as I heart restart doesn't) but I guess it could – grucha Dec 21 '10 at 8:41
I did it too and it got worked. I wonder why /etc/init.d/supervisor restart doesn't work when manual stop and start do. – Kirill Feb 29 '12 at 12:33
Worked for me, though the service didn't work so I just ran ps aux | grep supervisor and then sudo kill -HUP pid – Wayne Werner Aug 13 '12 at 3:04
This is dangerous as it will restart the whole of the supervisor daemon. – Mark Theunissen Feb 17 '13 at 20:04
supervisorctl reread can fix this aswell without restarting the service. – Jonathan Liuti Aug 27 '13 at 13:20

The correct answer is that supervisor requires you to re-read and update when you place a new configuration file. Restarting is not the answer, as that will affect other services. Try:

supervisorctl reread
supervisorctl update
share|improve this answer
This should be the correct answer. "supervisor reread" alone is not enough. – Miebster Oct 21 '13 at 16:04
+1 This is a better answer because it doesn't rely on Process Managers. – tidwall Jul 30 '14 at 15:29
"supervisorctl reread" alone is not enough, but wouldn't "supervisorctl update" suffice? According to the documentation "update" does a reread followed by a restart of any programs whose configuration was modified by the reread. – BlueBomber Sep 8 '14 at 22:03

Reloading the master supervisor process may work, but it will have unintended side effects if you have more than one process being monitored by supervisor.

The correct way to do it is to issue supervisorctl reread which causes it to scan configuration files for any changes:

root@debian:~# supervisorctl reread
gunicorn: changed

Then, simply reload that app:

root@debian:~# supervisorctl restart gunicorn
gunicorn: stopped
gunicorn: started
share|improve this answer
This is the best solution if you only want to read a changed/new config file and leave the rest of the running processes untouched. Supervisorctl will show the new app is avail. Add it to the (re)startable processes by issueing supervisorctl update. See also Mark's answer – Sjaak Trekhaak Jun 13 '13 at 7:23
This was not enough for me. supervisorctl update was necessary. – Yaroslav Nikitenko Jan 22 at 15:39

Make sure your supervisor conf files end in .conf

Took me a while to figure that one out. Hopefully it helps the next person.

share|improve this answer
Wasted an hour on the same issue - can't believe it was this simple. – Cabloo May 5 at 17:22
Thanks for listing this answer. For the life of me, I could not figure this one out. – Phillip Martin Jun 2 at 14:54

I had a similar problem ( myapp_live: ERROR (no such process) ) and it was because my process definition was

[program: myapp_live]

when it should have been


While this doesn't address the question that was asked, I was lead here by the Search that Be looking for a solution to my problem, so hopefully other people find it here, too.

share|improve this answer
Same here! I had left it as [program] only, following the docs, but making it [program:redis] made it work for me. Things sure get weird at times! – dotslash Jul 16 at 7:08

I encountered this problem using the supervisor package, version 3.0a8-1.1 from Ubuntu Server 12.10. I ended up solving the problem by reading the built-in help:

$ sudo supervisorctl help restart
restart <name>          Restart a process
restart <gname>:*       Restart all processes in a group
restart <name> <name>   Restart multiple processes or groups
restart all             Restart all processes

In particular you want to use the syntax:

sudo supervisorctl restart myapp_live:*

As the documentation states at -- "A [program:x] section actually represents a “homogeneous process group” to supervisor (as of 3.0)." So maybe the problem first surfaced in version 3.0.

PS: I'm new to supervisor; I'm using as an example of what a minimal configuration should look like.

share|improve this answer

I found this solution to be most convenient:

EDIT: before doing this check your supervisorctl path using which supervisorctl to make sure you are adding right path to sudoers.

Add this line to sudoers file using visudo (where: myappuser - the user that needs to restart your app, myapp - app name):

myappuser  ALL=(ALL) NOPASSWD: /usr/bin/supervisorctl restart myapp

And then simply:

sudo supervisorctl restart myapp

You are not tied to distribution's startup scripts and you give quite narrow privileges to user restarting your gunicorn app. Also, you don't need to care about pid. The command will not ask for password so it's suitable for auto-deployment bash/fabric scripts. On the other hand - you have to be aware, that if supervisorctl is vulnerable to some bug causing code execution a malicious user could use this sudo privilege to run code as root (but as far as I know no such bug was discovered for supervisord and it's a big thing to find such vulnerability).

share|improve this answer

I've found the init.d scripts to be unreliable on a variety of different Ubuntu/Debian versions. The way to do it is this:

sudo supervisorctl reload
share|improve this answer
This is not the right way to do it although it will work in many circumstances. @burhan-khalid answer is the right one, and provides an explanation for it. – glarrain Apr 26 '13 at 18:26

Reading the code of here:

You can see that supervisorctl update (function do_update) is calling reloadConfig() exactly as supervisorctl reread (function do_reread) does.

So i think that calling reread is not necessary if you call update after it.

From the output of git blame it has been like this since at least since july 2009.

share|improve this answer

I had installed supervisrod with yum install, which installed supervisor of version v2.*. Supervisor supports external includes only from version 3. Had to use easy_install instead, to install supervisor v3.

share|improve this answer
This was also my issue, it will probably occur on all Centos 6.5 or less installs. – bearrito Feb 18 '15 at 0:42

Be careful with symlinks and include files on Supervisor. It would allow any person with w privilege on /home/myapp/live/deploy/supervisord_live.ini to change the ini file and start any malicious code. This ini files should be inside your supervisor's conf directory or in any subdir under it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.