Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can not connect to IIS using lftp as you can see here:

<--- 200 Language is now English, UTF-8 encoding.
---> OPTS UTF8 ON
<--- 200 OPTS UTF8 command successful - UTF8 encoding now ON.
---> HOST x.x.x.x
<--- 504 Server cannot accept argument.
---> USER bla
<--- 331 Password required for hgtrf.
---> PASS blabla
<--- 230 User logged in.
---> PWD
<--- 257 "/" is current directory.
---> PBSZ 0
<--- 200 PBSZ command successful.
---> PROT P
<--- 534 Policy denies SSL.
---> PASV
<--- 227 Entering Passive Mode (x.x.x.x,194,118).
---- Connecting data socket to (x.x.x.x) port 49782
**** Socket error (Connection refused) - reconnecting
---> LIST
---> ABOR
---- Closing aborted data socket
---- Closing control socket

I could connect, list, retrieve and send files using standard ftp command. Do you have any suggestion?

share|improve this question

1 Answer 1

Just make sure you have disabled ssl:

lftp -d -u user,password -e "set ftp:ssl-allow no" server-address
share|improve this answer
    
I had an issue logging in with lftp to a PureFTPd server. The client machine was Windows 7 (lftp running in Cygwin). I could not even do an `ls', but the answer helped! –  gerikson Sep 8 '11 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.