Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Any pointers would be helpful.

Text below is taken out of fiddler. This happens once in few days. Usually gets solved by restarting.

Thanks.

Request to a html page from SSL is returned with a png file.

GET https://www.@@@.com/account.html HTTP/1.1
Host: www.@@@.com
Connection: keep-alive
Referer: https://www.@@@.com/account.html
Cache-Control: max-age=0
Accept: application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.215 Safari/534.10
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,en;q=0.8
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3
Cookie: JSESSIONID=@@@

RESPONSE

HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Accept-Ranges: bytes
ETag: W/"4110-1287034824000"
Last-Modified: Thu, 14 Oct 2010 05:40:24 GMT
Content-Type: image/png
Content-Length: 4110
Date: Sat, 11 Dec 2010 15:22:40 GMT

SERVER.XML

<Connector compression ="on" executor="tomcatThreadPool" port="80" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="443"/>
        <Connector compression ="on"  executor="tomcatThreadPool" port="443" protocol="HTTP/1.1" SSLEnabled="true" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" address= ..
share|improve this question

https://issues.apache.org/bugzilla/show_bug.cgi?id=50957

Was probably the problem with 7.0.2 version only. Fixed after upgrading to current version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.