Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

has anybody solved the problem of installing GDChart on CentOS 5.5 Linux (I've tried both 32 and 64 bit versions)?

I have:

# rpm -qa | grep -i php
php-pear-1.4.9-6.el5
php-gd-5.1.6-27.el5
php-ldap-5.1.6-27.el5
php-pgsql-5.1.6-27.el5
php-5.1.6-27.el5
php-pdo-5.1.6-27.el5
php-common-5.1.6-27.el5
php-cli-5.1.6-27.el5
php-devel-5.1.6-27.el5

And the "pecl" seems to find GDChart in its repository:

#  sudo pecl search GDChart
Retrieving data...0%....50%....Matched packages, channel pecl.php.net:
=======================================
Package Stable/(Latest)    Local
GDChart -n/a-/(0.2.0 beta)       GDChart Based Graphing Interface

But installing it fails:

# sudo pecl install GDChart
Failed to download pecl/GDChart within preferred state "stable",
latest release is version 0.2.0, stability "beta", use
"channel://pecl.php.net/GDChart-0.2.0" to install
Cannot initialize 'GDChart', invalid or missing package file
Package "GDChart" is not valid
install failed

Ok, then I try the suggested "URL":

# sudo pecl install "channel://pecl.php.net/GDChart-0.2.0"
pecl/gdchart requires PHP extension "gd"
No valid packages found
install failed

But I do have both "gd" and "php-gd" rpms installed and enabled:

# cat /etc/php.d/gd.ini
; Enable gd extension module
extension=gd.so

And phpinfo() shows "gd" as enabled too:

GD Support  enabled
GD Version  bundled (2.0.28 compatible)
FreeType Support  enabled
FreeType Linkage  with freetype
FreeType Version  2.2.1
GIF Read Support  enabled
GIF Create Support  enabled
JPG Support  enabled
PNG Support  enabled
WBMP Support  enabled
XBM Support  enabled 

Any suggestions please, except compiling it by hand? Alex

share|improve this question

1 Answer 1

up vote 0 down vote accepted

pecl command is horrible at telling you why something is erroring out. I'll recreate what you are going though

wget http://pecl.php.net/get/gdchart-0.2.0.tgz
tar zxfv gdchart-0.2.0.tgz 
cd gdchart-0.2.0
phpize
./configure
make

A lot of stuff

In file included from /home/mzupan/gdchart-0.2.0/gdchart.c:35:0:
/home/mzupan/gdchart-0.2.0/gdchart-src/gdc.h:27:16: fatal error: gd.h: No such file or directory
compilation terminated.

So install gd-devel

sudo yum install gd-devel

Then your pecl install should work

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.