Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hey guys, I'm trying to install SVN on CentOS 5. Unfortunately a simple yum install isn't going to work (afaik) because I'm using the DirectAdmin control panel.

When it comes to running 'make' I get this error:

/usr/bin/ld: cannot find -lexpat

I'm new to installing things without yum (!) so am a bit lost. Do you have any advice on how to get past this hurdle?

Just to give a little more context to the error;

/apache   -I/usr/include/apache -I/etc/svn-install/subversion-1.6.2/sqlite-amalgamation  -o subversion/svn/util.o -c subversion/svn/util.c
cd subversion/svn && /bin/sh /etc/svn-install/subversion-1.6.2/libtool --tag=CC --silent --mode=link gcc  -g -O2  -g -O2 -pthread   -rpath /usr/lib -o svn  add-cmd.o blame-cmd.o cat-cmd.o changelist-cmd.o checkout-cmd.o cleanup-cmd.o commit-cmd.o conflict-callbacks.o copy-cmd.o delete-cmd.o diff-cmd.o export-cmd.o help-cmd.o import-cmd.o info-cmd.o list-cmd.o lock-cmd.o log-cmd.o main.o merge-cmd.o mergeinfo-cmd.o mkdir-cmd.o move-cmd.o notify.o propdel-cmd.o propedit-cmd.o propget-cmd.o proplist-cmd.o props.o propset-cmd.o resolve-cmd.o resolved-cmd.o revert-cmd.o status-cmd.o status.o switch-cmd.o tree-conflicts.o unlock-cmd.o update-cmd.o util.o ../../subversion/libsvn_client/ ../../subversion/libsvn_wc/ ../../subversion/libsvn_ra/ ../../subversion/libsvn_delta/ ../../subversion/libsvn_diff/ ../../subversion/libsvn_subr/ /etc/httpd/lib/  -lexpat /etc/httpd/lib/ -luuid -lrt -lcrypt  -lpthread -ldl
/usr/bin/ld: cannot find -lexpat
collect2: ld returned 1 exit status
make: *** [subversion/svn/svn] Error 1


share|improve this question

closed as off-topic by HopelessN00b Apr 3 at 16:58

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

You are missing the expat development package


yum install expat-devel

and rerun make after that

though I doubt this question belongs on SF

share|improve this answer
sorry :( is there another stack overflow / serverfault-type website it would be better on? – furnace Jun 6 '09 at 18:08
Don't worry about it too much ;-) Did you manage to compile it yet? – wzzrd Jun 6 '09 at 19:49

I might suggest going to the official Subversion site ( There you get a link to collabNet BINARY packages for Redhat versions 4,5 and others.

Since CentOS is really a recompilation of Redhat AS sources you should have no problem using the RedHat binary packages. Its also nice as all the necessary binaries, modules and such are included.

share|improve this answer