Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having problems trying to ssh to a remote server from my wireless at work.

I tried removing the .ssh folder and such but I can't make it work. At first, I found it was a wireless driver problem in Ubuntu 10.04, but after that I could access from home.

These are all the facts I could gather.

  • If I do a failed login it immediately answers me. If I enter the correct password it just hangs forever.
  • I can do ssh from my wireless at home
  • Co-workers can do ssh from the same wireless I cannot (They also have Ubuntu 10.04)

EDIT: Output after logging in. After printing this it just hangs there.

debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.utf8

And this is my ssh_config

SendEnv LANG LC_*
HashKnownHosts yes
GSSAPIAuthentication yes
GSSAPIDelegateCredentials no

EDIT 2: auth.log data

Dec 13 16:56:26 sshd: reverse mapping checking getaddrinfo for MY_IP failed - POSSIBLE BREAK-IN ATTEMPT!
Dec 13 16:56:32 sshd: Accepted password for MY_USER from MY_IP port SOME_PORT ssh2
Dec 13 16:56:32 sshd: pam_env(sshd:setcred): Unable to open env file: /etc/default/locale: No such file or directory
Dec 13 16:56:32 sshd: pam_unix(sshd:session): session opened for user MY_USER
Dec 13 16:56:32 sshd: pam_env(sshd:setcred): Unable to open env file: /etc/default/locale: No such file or directory

I guess the POSSIBLE BREAK-IN ATTEMPT is the issue

share|improve this question
2  
Post the output of ssh -v user@host. –  EEAA Dec 13 '10 at 15:46
    
You can also try tcpdump to check for outgoing and incoming packets. –  Khaled Dec 13 '10 at 15:54
2  
sounds an awful lot like (reverse) DNS issues. Anything in /var/log/auth.log? –  SpamapS Dec 13 '10 at 16:28

1 Answer 1

It could be a mis-configured firewall interfering with TCP windows. This is pretty rare these days but leads to similar behavior. You don't mention what OS your coworkers are using. Linux is more sensitive to broken firewalls than other OSes in my experience.

I can't remember which options to disable, but try these as root:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
echo 0 > /proc/sys/net/ipv4/tcp_timestamps

That might fix it until the next reboot. If it works you can add it to /etc/sysctl.conf to make it permanent, but it will lessen performance when sending big files.

share|improve this answer
    
It did not work. I updated the answer, they use the same OS (Ubuntu 10.04) –  Lombo Dec 13 '10 at 19:08
    
Try setting "UseDNS no" in sshd_config. Again, not sure it will help. –  mfarver Dec 13 '10 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.