Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Microsoft Hyper-V Server 2008 R2 and have 2 Linux guests running. I have noticed that if I increase the number of processors that are available to the Linux guest networking doesn't seem to work when booted into the OS. It does look like it was able to get an IP address from DHCP, but if I try to renew with dhclient ethx then it timesout saying that a DHCP server hasn't responded.
However, once I set the number of processors to one then it works perfectly.

Specs:
Legacy network adapter
Ubuntu 10.04

Am I doing something wrong?

share|improve this question
add comment

2 Answers

Have you installed the Linux Integration Component? SMB should work even without them, but if you're running into issues like you described, it's likely from not having an enlightened Linux install.

share|improve this answer
    
The Linux Integration Components don't work out of the box on Ubuntu. –  MattB Dec 14 '10 at 15:25
    
Not 'out of the box', but it will work without too much effort. Here are some documented installs on Ubuntu 10.04 blogs.technet.com/b/enterprise_admin/archive/2010/03/09/… and blog.allanglesit.com/Blog/tabid/66/EntryId/53/…. I've installed it on 8.04 and it works well. 10.04 is supposed to be easier. –  Scott Forsyth - MVP Dec 14 '10 at 15:33
add comment
up vote 1 down vote accepted

To addon to Scott's comment, the solution is to enable the modules described in this article: http://blogs.technet.com/b/enterprise_admin/archive/2010/03/09/linux-and-hyper-v-the-easy-way-brown-and-serve.aspx

After I ran through the steps everything worked great in Ubuntu.

In case those articles get taken down by someone or moved here are the steps:

Open /etc/initramfs-tools/modules with your favorite editor, add the following lines:
hv_vmbus
hv_storvsc
hv_blkvsc
hv_netvsc

Run the following as root:

update-initramfs –u

And reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.