Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I traced an issue down on one of our servers to an incorrect section in the .config file for an AppPool. If I manually remove the section from the c:\inetpub\temp\AppPools\thisAppPool.config which relates to one specific asp file (let's say site/epub/webservice.asp) then the web services work fine. However, if I then change a setting in IIS Manager, it overwrites this and re-adds the incorrect section.

I know how I can specify settings around authentication etc at the Virtual Directory level, but not at the file level (other than by editing the config file, which then gets lost).

Any ideas how I can stop this problem returning (other than by never changing things in the IIS Manager!)?

OS is Windows Server 2008 R2, IIS7

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can follow the blog to enable File Level Authentication in IIS 7/7.5 using IIS Manager. Also check the entry that can be seen in the apphost.config file. I hope you are entering the setting correctly.

There are few bugs in IIS 7.5 which are supposed to be fixed with the SP1 release.

share|improve this answer
    
Awesome - exactly what I was looking for. Somehow this one asp file had been set to run as an invalid user! –  x3ja Dec 15 '10 at 4:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.