Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to upgrade RAM in a Sun T5120 server, replacing 2GB (Sun P/N: 501-7953-01) with 8GB DIMMs (Sun P/N: 511-1262-01).

When bringing up the host system, I get the following errors on the ILOM:

-> show faulty
Target              | Property               | Value                           
--------------------+------------------------+---------------------------------
/SP/faultmgmt/0     | fru                    | /SYS/MB                         
/SP/faultmgmt/0/    | timestamp              | Dec 14 15:29:42                 
 faults/0           |                        |                                 
/SP/faultmgmt/0/    | sp_detected_fault      | /SYS/MB/CMP0/MCU3 Forced fail   
 faults/0           |                        | (IBIST)                         
/SP/faultmgmt/0/    | timestamp              | Dec 14 15:29:28                 
 faults/1           |                        |                                 
/SP/faultmgmt/0/    | sp_detected_fault      | /SYS/MB/CMP0/MCU2 Forced fail   
 faults/1           |                        | (IBIST)                         
/SP/faultmgmt/0/    | timestamp              | Dec 14 15:29:13                 
 faults/2           |                        |                                 
/SP/faultmgmt/0/    | sp_detected_fault      | /SYS/MB/CMP0/MCU1 Forced fail   
 faults/2           |                        | (IBIST)                         
/SP/faultmgmt/0/    | timestamp              | Dec 14 15:28:59                 
 faults/3           |                        |                                 
/SP/faultmgmt/0/    | sp_detected_fault      | /SYS/MB/CMP0/MCU0 Forced fail   
 faults/3           |                        | (IBIST)                         
/SP/faultmgmt/1     | fru                    | /SYS                            
/SP/faultmgmt/1/    | timestamp              | Dec 14 15:29:42                 
 faults/0           |                        |                                 
/SP/faultmgmt/1/    | sp_detected_fault      | Dec 14 15:29:42 ERROR:          
 faults/0           |                        | Unsupported memory              
                    |                        | configuration

As you can see, the only error message I get is "Unsupported memory configuration".

Note that I'm absolutely sure that I placed in the DIMMs in the correct slots.

Might this issue be related to the Voltage of the DIMMs? Any suggestions on how to trouble-shoot this issue?

This issue seems to be similar to the one explained at "Inserted disabled" while upgrading Sun Sparc t5120 memory. However the given link http://docs.sun.com/source/820-4445-10/chapter1.html seems to point to an inexistent page...

share|improve this question
    
That document is at v13 now docs.sun.com/source/820-4445-13/index.html –  Iain Dec 14 '10 at 17:28
    
Hi, I had same issue but it was solved by my co-worker. I think it was a problem with DIMMs order on the motherboard or something similar. Get luck. –  SourceRebels Dec 15 '10 at 17:33
    
I'm sure that the order of the DIMMs is correct (tho I tried other combinations too). I even swapped the DIMMs around, just to see whether it would make a difference. No luck unfortunately :/ –  watain Dec 15 '10 at 18:49
add comment

3 Answers

This is what the SUN manual has to say on T5120 memory

FB-DIMM Configuration Guidelines

Use the guidelines described in this topic when installing, upgrading, or 
replacing FB-DIMMs:

* There are a total of 16 slots that support industry-standard FB-DIMMs.
* Supported FB-DIMM capacities are 1 GByte, 2 GByte, 4 GByte, and 8 GByte.
* Valid quantities of FB-DIMMs are 4, 8, or 16.
* All FB-DIMMs in the server must be the same capacity.
* All FB-DIMMs in a branch must have the same part number.
Note - FB-DIMMs that run on 1.5V are not supported in this server. An FB-DIMM 
that runs on 1.5V is sometimes noted with an LV on the part number label. Do not
install such FB-DIMMs in this server.
share|improve this answer
1  
All DIMMs are 8G, same part number, I inserted a total of 4 DIMMs in the server. Looks like everything seems to be fine with the memory configuration, however I'm not sure about the voltage. There's nothing on the DIMMs indicating the exact voltage. Is there a way I could figure out whether these are 1.5V or 1.8V? Maybe a command on the ILOM/ALOM? –  watain Dec 14 '10 at 17:54
add comment

Can you detail your memory configuration please, slot by slot - you're observing the 'banks of four modules must be the same' rule right?

share|improve this answer
1  
I inserted 4x 8G DIMMs in total, slots from left to right (as seen as from the front of the T5120): 3, 7, 8, 12 (first slot = slot 0). Exactly as in this picture (not being a picture of my T5120 however): tomcopeland.blogs.com/T5120.jpg. The names of the occupied slots are: /P0/BR0/CH0/D0, /P0/BR1/CH0/D0, /P0/BR2/CH0/D0, /P0/BR3/CH0/D0. Do you need more information? –  watain Dec 14 '10 at 17:48
add comment
up vote 0 down vote accepted

The problem was solved quite long time ago already, but I would like to share the solution in case anybody faces the same or a similar problem.

I noticed that not all DIMMs had the same revision number, although the part number was the same for each DIMM. So I decided to try using only identical DIMMs, i.e. all of them having the same revision number. I even verified that the serial numbers were continuous from the first DIMM up to the last one. The problem disappeared after booting up the server with this memory configuration, the "unsupported memory configuration" error message was gone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.