Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to connect to Windows Server 2008 network share on Ubuntu, but for some reason it is not working.

I have the following entries in my fstab:

//server/foo    /mnt/foo    cifs    username=aron,password=foobar    0       0
//server/bar  /mnt/bar  cifs    username=aron,password=foobar    0       0

I get the following error after calling mount -a:

mount error(110): Connection timed out Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

The output of dmesg | tail is:

[ 6697.441061] CIFS VFS: Error connecting to socket. Aborting operation
[ 6697.441078] CIFS VFS: cifs_mount failed w/return code = -110

I have no clue about why this command is timing out. Any help is appreciated.

EDIT: the OP explained this was only happening when trying to mount over a VPN connection, but it seems to happen with a physical connection as well.

share|improve this question
    
What type of VPN are you using? What do you get when you try to do a traceroute to the server you are trying to mount? –  Zoredache Dec 14 '10 at 21:50
    
Thanks for the reply; I just tried using a physical connection and am getting the same problem (my bad). It seems VPN is not the problem here. –  Aron Rotteveel Dec 15 '10 at 8:58

2 Answers 2

up vote 1 down vote accepted

Solved the problem.

It turned out I had an entry in /etc/hosts that made my DC hostname resolve to a different IP address than the primary reverse resolver.

IE:

192.168.1.160 server

While 192.168.1.160 did not resolve back to this host.

I edited the hosts entry to reflect the correct IP-adress, which solved the issue.

share|improve this answer

I whould also put the domain=name in the options -o

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.