Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hey all i have followed this page to a "T": http://learn.iis.net/page.aspx/321/configure-ftp-with-iis-7-manager-authentication/

in setting up the FTP server. I have also done the firewall thing with the svchost giving that permission.

I use the command prompt to test the ftp and i always get

ftp>

It never asked me for a user name or password.

When i type this into a browser:

ftp.myservernamehere.com:30001

it prompts me for a username and password which i enter what i added in those steps above and it never logs me in!!!! Keeps asking for username and password!!!

What in the world am i doing wrong?!?!?

David

When running IIS7 FTP

    [R] Connecting to ftp.domain.com -> DNS=ftp.domain.com IP=**.***.***.*** PORT=30001
[R] Connected to ftp.domain.com
[R] 220 Microsoft FTP Service
[R] USER theuser
[R] 331 Password required for theuser
[R] PASS (hidden)
[R] 230 User logged in.
[R] SYST
[R] 215 Windows_NT
[R] FEAT
[R] 211-Extended features supported:
[R]  LANG EN*
[R]  UTF8
[R]  AUTH TLS;TLS-C;SSL;TLS-P;
[R]  PBSZ
[R]  PROT C;P;
[R]  CCC
[R]  HOST
[R]  SIZE
[R]  MDTM
[R]  REST STREAM
[R] 211 END
[R] CWD /
[R] 250 CWD command successful.
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,20,192,246).
[R] Opening data connection IP: **.***.***.*** PORT: 49398
[R] Data Socket Error: Connection refused
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,20,192,247).
[R] Opening data connection IP: **.***.***.*** PORT: 49399
[R] Data Socket Error: Connection refused
[R] List Error

When running Filezilla server log

Creating listen socket on port 30001...
Server online
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> Connected, sending welcome message...
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> 220-FileZilla Server version 0.9.37 beta
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> 220 Please visit http://sourceforge.net/projects/filezilla/
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> USER userhere
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> 331 Password required for userhere
(000027)12/15/2010 9:33:08 AM - (not logged in) (**.***.***.***)> PASS *******
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 230 Logged on
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> SYST
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 215 UNIX emulated by FileZilla
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> FEAT
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 211-Features:
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  MDTM
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  REST STREAM
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  SIZE
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  MLST type*;size*;modify*;
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  MLSD
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  UTF8
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  CLNT
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)>  MFMT
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 211 End
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> CLNT FlashFXP 3.0.1044
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 200 Don't care
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> CWD /
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 250 CWD successful. "/" is current directory.
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> PWD
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 257 "/" is current directory.
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> TYPE A
(000027)12/15/2010 9:33:08 AM - userhere (**.***.***.***)> 200 Type set to A
(000026)12/15/2010 9:19:37 AM - userhere (**.***.***.***)> PORT 192,168,1,7,4,166
(000026)12/15/2010 9:19:37 AM - userhere (**.***.***.***)> 200 Port command successful
(000026)12/15/2010 9:19:37 AM - userhere (**.***.***.***)> LIST -al
(000026)12/15/2010 9:19:37 AM - userhere (**.***.***.***)> 150 Opening data channel for directory list.
(000026)12/15/2010 9:19:38 AM - userhere (**.***.***.***)> 425 Can't open data connection.
(000026)12/15/2010 9:19:45 AM - userhere (**.***.***.***)> TYPE I
(000026)12/15/2010 9:19:45 AM - userhere (**.***.***.***)> 200 Type set to I
(000026)12/15/2010 9:19:45 AM - userhere (**.***.***.***)> SIZE GS108T-V3.0.4.10.hex
(000026)12/15/2010 9:19:45 AM - userhere (**.***.***.***)> 550 File not found
share|improve this question

2 Answers 2

up vote 3 down vote accepted

Firstly, I would recommend that you stop using the command prompt and certainly stop using Internet Explorer for connecting to an FTP. Use a decent FTP program instead, something like FileZilla which will show you the server responses you receive which you can use to resolve your login issues.

As for the lonely ftp>, if you start a command prompt and type ftp you'll get nothing more than an ftp> prompt. You need to type in open ftp.domain.com at this prompt before you'll be requested to log in with a username or password (unless you typed ftp ftp.domain.com in the first instance!)

So, two options:

C:\Users\User>ftp

ftp>open ftp.domain.com:30001

or

C:\Users\User>ftp ftp.domain.com:30001

I've got an FTP running on Windows Server 2008 R2 with IIS Manager users so if you need anything further, let me know.

share|improve this answer
    
Thanks for the reply, Lewis. I did do the ftp ftp.domain.com:30001 and it still just gives me that ftp> line without being able to type in the user name and password.. –  user40679 Dec 15 '10 at 17:21
    
I've got filezilla server up and working on it but i can not seem to connect using passive mode or upload a file without it telling me 425 Can't open data connection. See OP for the list of what its doing when trying to upload a file. –  user40679 Dec 15 '10 at 17:26
    
@StealthRT: why in the world did you install FileZilla server on a box where IIS's own FTP service is running? Lewis was suggesting you to use the FileZilla client :-) Having two FTP servers on the same box isn't going to help you much. –  Massimo Dec 15 '10 at 17:52
    
@Massimo. I turned off the MSFTP when i tested the filezilla server. And i turned off filezilla server when testing MSFTP. I'm using Bulletproof FTP to log into the server. –  user40679 Dec 15 '10 at 17:54
    
@StealthRT: of course, otherwise they wouldn't work :-) I was only saying that changing your FTP server isn't going to solve your client/connection problems, unless the IIS FTP service was severely misconfigured. –  Massimo Dec 15 '10 at 18:00

Regarding your first problem (authentication): IIS's FTP service has lots and lots of authentication options, so there could be many reasons why it's not letting you in. The most common cause is logging in as an user which doesn't have read permissions on the root FTP directory, but there could be many, many more.

Regarding your second problem (unable to open data connection): this is usually a firewall issue. Where are you trying to connect from? Do you have the same problem if you run the client and the server on the same machine? Have you tried completely turning off Windows Firewall?

share|improve this answer
    
Ok, i finally added the user to the Local Useres and Groups and i am now able to log into the FTP via the MS FTP server. However, i am still getting the Data Socket Error: Connection refused and List Error :o( Check my OP for log. –  user40679 Dec 15 '10 at 19:06
    
@StealthRT: you dind't answer my questions; where is the server and where is the client? Are they on the same computer? On the same network? On different networks? If you try to run both on the same computer, does it work? This is very likely a network and/or firewall problem, so nothing can be said unless you tell more about your network setup. –  Massimo Dec 15 '10 at 22:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.