Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to set up AD FS 2.0 on a Windows Server 008 R2 Enterprise, but I am stuck on getting an error when trying to run the "AD FS 2.0 Federation Server Configuration Wizard":

Error message

The error states that "Microsoft .NET Framework 3.5 is required for the initial configuration wizard to run". I am absolutely certain that .NET 3.5 is installed on the server, yet the error message pops up, preventing me to complete the installation. The error dialog suggests "re-running the AD FS Installer". I have tried this, but it does not change a thing.

Has anyone seen this erroneous error before? Any ideas how to make it go away?

share|improve this question
    
Do you have .NET 3.5 installed via the Application Server role, or some other way? –  Jaxidian Jun 3 '11 at 17:03

1 Answer 1

Can you please check if the .Net 3.5.1 shows up as an installed feature in server manager? I also recommend installing any required updates (skip optional) for .Net framework suggested by windows update. There were some security updates as I recall but the presence of .net 3.5.1 suggests the required service pack is installed.

As a last resort I'd get the .net framework installation checked out using the .NET Framework Setup Verification Tool at http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.