Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to have two BIND servers keep their zones in sync. Usually easy enough. The tricky bit is that while both servers have external IPs, they are also on the same local subnet with internal IPs (I know name servers should be geographically separated... just humour me). They are both behind the same NAT router forwarding all traffic respectively. However when one server sends packets to the other external address they actually appear on the internal interface. In this situation Bind refuses to acknowledge the response and tries the transfer again.

The notifications from master to slave works fine, it's only when the slave requests a zone transfer from (eg.) 123.123.123.123 and gets a response from 192.168.0.1 that there is a problem.

Is there any way to allow this behaviour in bind?

share|improve this question
    
You should request the transfer and receive it using the private IPs. –  Khaled Dec 15 '10 at 15:21

1 Answer 1

up vote 2 down vote accepted

If both are behind the NAT router and have private IP addresses, you should be using those private IPs within the network rather than the public addresses. Configure BIND to use the private IPs for the master section on the secondary server, and add an also-notify option to the primary server and ensure the secondary's private IP is listed in the allow-transfer option on the primary as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.