Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was getting this error on my php script:

Fatal error: Call to undefined function xdiff_file_diff()

I realised that I didn't had the xdiff extension installed. When I tried to install it using the install pecl xdiff command, I got this errors (among other lines):

configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP configure: error: Please reinstall the libxdiff distribution

Then I installed re2c and libxdiff:

wget http://www.compdigitec.com/labs/files/re2c_0135_redhat.rpm
wget ftp://ftp.task.gda.pl/vol/vol1/ftp.pld-linux.org/dists/2.0/PLD/i386/PLD/RPMS/libxdiff-0.7-1.i386.rpm
rpm -ivh re2c_0135_redhat.rpm
rpm -ivh libxdiff-0.7-1.i386

But after that I still get the same errors.

PS: I've Googled a LOT and I found a couple of people with this problem but they didn't get an answer either :(

share|improve this question

migrated from stackoverflow.com Dec 15 '10 at 23:36

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.