Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All my apache plugins returns the same value :

/usr/share/munin/plugins# munin-run apache_volume volume443.value U

Here is my config in /etc/munin/plugin-conf.d/munin-node

[apache_*] env.ports 443

Some have an idea where is the problem ?

Thanks in advance

share|improve this question
up vote 2 down vote accepted

I found the solution.

The apache scripts are not compatible with ssl. You have to use modified version on :
http://munin-monitoring.org/attachment/wiki/PluginCat/apache_volume
http://munin-monitoring.org/attachment/wiki/PluginCat/apache_accesses
http://munin-monitoring.org/attachment/wiki/PluginCat/apachessl_processes

Be sure to have the perl libraries LWP::UserAgent and Crypt::SSLeay installed

Modify also /etc/munin/plugin-conf.d/munin-node :
[apache_*]
env.ports 443
env.url https://localhost:443/server-status?auto

It works fine after that ;-)

share|improve this answer
    
Thanks for that! Only the links to the scripts are not longer valid. But the changes to the scripts are easy. See also at my answer. – Steffen Mar 2 at 8:26

Have you set up apache to provide status information? in /etc/apache2/mods-available/status.conf you need something like

<IfModule mod_status.c>
ExtendedStatus On
<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from localhost ip6-localhost 127.0.0.1 ::1
</Location>
</IfModule>
share|improve this answer
    
Yes. I have tried also with your conf to test. Same result. when I go to the /server-status page, it works normally. </code>munin-run apache_volume volume443.value U order:/usr/share/munin/plugins# a2enmod status Module status already enabled </code> – hotips Dec 16 '10 at 10:46

At first: See also my EDIT below! May be you don't must change the scripts!

The answer of "hotips" is right (+1 for that), but only the links are not longer valid. But you can do the changes in the three scripts by self. It's easy. After installing the perl packages LWP::UserAgent and Crypt::SSLeay (like it was described by "hotips") edit each script and change following lines:

...
my $ua = LWP::UserAgent->new(timeout => 30,
           agent => sprintf("munin/%s (libwww-perl/%s)", $Munin::Common::Defaults::MUNIN_VERSION, $LWP::VERSION));
...
...
    my $response = $ua->request(HTTP::Request->new('GET',$url));
...

into:

...
my $ua = LWP::UserAgent->new(timeout => 30,
            verify_hostname => 0,
            agent => sprintf("munin/%s (libwww-perl/%s)", $Munin::Common::Defaults::MUNIN_VERSION, $LWP::VERSION));
...
...
        my $response = $ua->get($url);
...

After that don't forget to add the configuration entries env.ports 443 and env.url https://localhost:443/server-status?auto to /etc/munin/plugin-conf.d/munin-node (also described by "hotips")

EDIT

Arrghhh! Find out an interesting thing. May be you don't need to change the scripts! In my case after installing the two perl packages and add the configuration entries the scripts working very well with SSL!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.