Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to install FastCGI on IIS 7.5 on my Windows 7 Home Premium box I use at home to do some random coding. However WPI doesn't show the FastCGI option and I can't find it in IIS at all...

How do I do this just one installer, I've seen FastCGI installs for IIS 5.1 and IIS6 but it says FastCGI should be a part of IIS already... It is not in WPI and not in "Turn windows features on or off"...

I'm lost!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You don't need to run a separate install to use FastCGI. It is integrated with IIS7.5 but you need to activate the CGI feature on your machine. To do this:

  1. Go to Control Panel...Programs...Turn Windows Features on or off.
  2. Expand Internet Information Services...World Wide Web Services...Application and Development Features.
  3. Check the box next to CGI.
  4. Click 'OK'.

After the feature activation finishes, go to IIS manager on your local machine. You should see the FastCGI Settings under the 'IIS' section.

A TechNet article provides more detail here.

Configuration details for FastCGI on TechNet are provided here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.