Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been using the standard terminal-based ssh client that ships with OS X (10.5.8) without any problems for years now, and suddenly it has stopped working and I can't figure out why.

I try to login to any server via a typical SSH command, but it seems like a connection attempt is never made. I use the Little Snitch network monitor, and I'm seeing absolutely no traffic coming from ssh/terminal when I type in the SSH command.

I've tried via hostname and by IP address, and nothing. It seems that the DNS lookup happens correctly because when I use the hostname it resolves it to the correct IP address. But then nothing happens.

When I run ssh with the -v flag, here's what I get for output (host names and IPs redacted for safety):

$ ssh -v user@hostname.domain
OpenSSH_5.2p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to hostname.domain [correct_ip_address] port 22.
debug1: connect to address correct_ip_address port 22: Operation timed out
ssh: connect to host hostname.domain port 22: Operation timed out  

The odd bit is that this seems to have just happened randomly, not after a software update or system change of any sort. I'm not having any other networking issues, and a traceroute to the hostname works just fine.

Completely at a loss here. Not sure where to look or what could possibly be causing this problem.

EDIT: Solved — it was a routing issue. Not sure exactly what, but restarting the main router of the network I'm on fixed it.

share|improve this question

1 Answer 1

Looks like your problem is either network-related (firweall or some device is killing this connection between you and the server), but more likely the problem is on the server end.

Operation timed out usually means it tried to make a connection (and the connection wasn't refused) but waited so long to "hear back" from the server that it just had to stop waiting and abort.

share|improve this answer
    
If you can connect via ssh from another client to the server, then you might have a local problem, esp.a firewall. Bad routing and other problem usually come back with different errors. –  benc Dec 17 '10 at 8:19
    
You're right, it was a network problem. I thought since I didn't see any outbound traffic on Little Snitch that the requests weren't leaving my macbook. The fact that traceroute returned proper results further befuddled me. Turns out that it was a problem with the router I'm behind in the office. Restarting the router fixed this. –  disbelief Dec 17 '10 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.