Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a peculiar problem on one of my servers at the moment, which seems to be related to authentication in some way, but I have no idea how to find the root of the problem.

I have a folder on the server D:\Somefolder\Logs.

If I am connected to the server via an RDP terminal, so essentially "local", I cannot access that folder - I get an access denied.

If I am connecting from my machine to it using the share \server\d$\Somefolder\Logs, I can access it.

I'm logging in to both machines as the same user. Permissions on the folder seem quite simple, CREATOR OWNER, SYSTEM and Administrators. I am a Domain Admin, and they are in the local "Administrators" group.

It is also affecting things like access to SQL Server, so I don't think it's a simple folder-permissions thing. For example, I cannot connect SQL Management Studio to all the local SQL instances using a domain account, but I can if I connect remotely to it.

share|improve this question

2 Answers 2

I just ran into this exact issue myself. It was due to me disabling LM hashes through GPO and setting the LM authentication to NTLMv2 only. Please see this Microsoft article on how to fix it: http://support.microsoft.com/kb/968389

If that doesn't work, try uninstalling update 968389 and then re-installing it. See this thread: UNC Path fails by IP "no network provider accepted the given network path", but works using hostname

The Microsoft Fix-it didn't work for me, but the uninstall/reinstall of the update did.

I know this is over a year old but I hope it helps anyone hitting this thread coming from Google like I did.

Edit: It appears the Microsoft fix-it didn't actually change the registry like it was supposed to, make sure to manually check the keys it was supposed to change.

share|improve this answer

I would look in two areas, first I would take ownership of the folder and then change the permisision: stop the replication, this triggers the "do you want to copy the permission" dialog, copy the permissions and change them giving full control to my user.

The other place I would look is in the policies. There are some permission that are blocked for locally logged users. I know, the administrator can do anything, but obviously in this case he cannt, so something is missconfigured.

share|improve this answer
    
It's also affecting accessing the SQL Server instance on that server though, and I didn't think that goes through file permissions - isn't that all handled by the server process? –  Cylindric Dec 20 '10 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.