Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two SQL Server services in Sql Server Configuration Manager: SQLEXPRESS and MSSQLSERVER. I have no idea what the differences are. I think that SQLEXPRESS is the free version, but I don't know how I got it and I can't remove it either because it doesn't show up in remove programs.

But here's where it gets weird: I installed SQL Server Enterprise, and during installation I specified a local user (SQLServices) to be used for all SQL Server services. Okay, so this worked for SQL Server Analysis Services (MSSQLSERVER) and SQL Server Integration Services10.0 (MSSQLSERVER), they are running under this user. But SQL Server (MSSQLSERVER) does NOT run and gives an error that it can't connect/time out etc., and SQL Server (SQLEXPRESS) runs, but under NT AUTHORITY\NETWORK SERVICE. I stopped this, and tried to run the SQL Server (MSSQLSERVER), but it keeps timing out on me. What's going on?

share|improve this question
add comment

1 Answer

You are correct that SQLEXPRESS is the free version. Not sure why it wouldn't show up in the list of programs to remove.

More than likely, SQLEXPRESS being present or running has nothing to do with trouble you are having with SQL Ent; they can run side-by-side as separate instances (barring any misconfiguration which would explicitly prevent it - which would likely have to be done purposefully)

NETWORK SERVICE is, I believe, the default that SQLEXPRESS will run under.

As for why SQL Ent is not running; exactly what error(s) are you getting? Have you checked the logs? It's possible the user in question does not have all the rights or permissions needed to run SQL Server.

share|improve this answer
    
The error is as follows: eventNo 7000. The SQL Server (MSSQLSERVER) service failed to start due to the following error: SQL Server (MSSQLSERVER) is not a valid Win32 application. My machine is windows 7, 64 bit. I did install sql server enterprise 64bit. Also, when I change the password on the SQL Service (MSSQLSERVER), it says Access Denied [0x80070005]. –  TheDude Dec 17 '10 at 16:56
    
Hmmm... that type of error seems to typically be caused by the service's entry somehow not correctly pointing to the executable. Can you view the entry in Services and verify that the path it is executing is correct? It should be contained in parenthesis if there are any spaces in the path too, btw. –  Andrew Barber Dec 17 '10 at 17:08
    
This is the path to the executable: "C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Binn\sqlservr.exe" -sMSSQLSERVER –  TheDude Dec 17 '10 at 17:36
    
OK, that looks correct to me. Does that file exist, and do you know if it's possibly corrupted in some way? You could actually execute it directly to test that. –  Andrew Barber Dec 17 '10 at 17:42
    
I installed it yesterday, nothing came up as error. The file does exist in that directory. BUT... I just noticed it's in the folder Program Files instead of Program Files(x86). This could explain why it says "Not a valid win32 application". But if this is it, how can I get the files to the Program Files (x86) directory? –  TheDude Dec 17 '10 at 17:52
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.