Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

we're trying to get awstats up and running on our IIS6 server. awstats is running fine and generating output and all that jazz... no problem there.

When trying to change the selected month/year in the output page though, it is trying to run awstats.pl through IIS, and coming up with a 404 error. To debug I made a simple hello.pl in my root, and tried to run that, also 404s.

I followed the directions on this page http://support.microsoft.com/kb/245225 regarding installing ActiveState Perl and then configuring IIS. I added the extension mapping on my directory and registered the web services extension as directed.

The perl scripts all run fine and output if run from the command line, so I know perl is good, but I can't get IIS to find the files.

Here is the configuration on my the home directory tab of my site: Home Directoy

Here is the configuration of my web service extension: alt text

I turned on directory browsing for this site, and when i get the listing of the directory, IIS actually does show the .pl files being in the directory. But if I click on one of them, I get the 404 error.

12/17 15:22 > Also tried adding .pl as a mime-type on my site's configuration. This did not help.

12/17 16:57 > Also tried Everyone Read/Execute permissions on both the Perl direcory and the directory housing awstats. This did not help.

share|improve this question

migrated from stackoverflow.com Dec 17 '10 at 20:43

This question came from our site for professional and enthusiast programmers.

1  
Seems more like a ServerFault question. –  kindall Dec 17 '10 at 19:29
    
Yah, I couldn't quite decide between the two. I guess I'll cross-post it there. –  eidylon Dec 17 '10 at 19:31
1  
@eidylon Don't create a new post on ServerFault. Wait for this topic to be moved there. –  Sinan Ünür Dec 17 '10 at 19:44

1 Answer 1

up vote 1 down vote accepted

Okay, I figured out how to get this working. Every direction every where that I found talked about pointing the Web Service Extension to perl.exe. No matter how I tweaked, I always got 404s.

I finally got it working by instead pointing the web service extension to perlis.dll. As soon as I did that - BOOM! It worked! WAHOO!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.