Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VPS that currently runs CentOS 5 and Plesk 9.0.1.

Right now the server runs PHP 5.1 but I really need to start running PHP 5.3. Is there a repository out there that would allow me to upgrade this without breaking the entire system?

Thanks

Josh Pennington

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I could be wrong, but I don't think Plesk 9 works with PHP 5.3, partly because of the reliance on the deprecated safe mode.

If you want to take the risk, and have sufficient backups, I believe the remi repository contains PHP 5.3. See here. If you end up doing a MySQL upgrade as well, make sure to do a full MySQL dump first, upgrade, then reimport the dump.

If you find PHP 5.2.14 would be suitable, you can use the atomic repositories: wget -q -O - http://www.atomicorp.com/installers/atomic | sh
yum update php
You may find that php -v gives an error about ioncube. If it does, go into /etc/php.d/ioncube.ini (or similar) and change the 5.1 or 5_1 to 5.2 or 5_2 (I can't remember for sure). You may also need to remove php-sqlite2 before you can upgrade on a Plesk server, but you're unlikely to be using it (check dependencies).

share|improve this answer

I supply a yum repository with PHP 5.3 in, which fits in with existing PHP setups when upgrading. I can't guarantee that Plesk will be happy with it though unless they've updated it to support PHP 5.3

http://www.webtatic.com/blog/2009/06/php-530-on-centos-5/

There is also the Zend Server Community Edition, which you may find more suitable, however it doesn't provide packages under the same naming conventions, so you would have to switch between packages.

http://www.zend.com/en/products/server-ce/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.