Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure Vyatta to act as a wifi to ethernet bridge. I am currently doing this with my windows desktop but want to move it to a dedicated Vyatta box. I have a typical linksys wireless router that operates as my access point. The wireless card in the Vyatta box works just fine and is able to connect when it is configured as a normal wireless client. When I create the bridge between eth0 and wlan0, clients on the lan "behind" Vyatta still can't connect. If I restart Vyatta in this state, it will also not get an IP address from the wireless network any longer.

Any help is greatly appreciated.

Here is my config:

vyatta@Vinz-Clortho:~$ show configuration 
interfaces { 
    bridge br0 { 
        aging 300 
        hello-time 2 
        max-age 20 
        priority 0 
        stp false 
    } 
    ethernet eth0 { 
        bridge-group { 
            bridge br0 
        } 
        duplex auto 
        hw-id 00:0d:60:c4:e5:cc 
        smp_affinity auto 
        speed auto 
    } 
    loopback lo { 
    } 
    wireless wlan0 { 
        address dhcp 
        bridge-group { 
            bridge br0 
        } 
        mode g 
        security { 
            wpa { 
                mode both 
                passphrase **************** 
            } 
        } 
        ssid SRT 
        type station 
    } 
} 
service { 
    ssh { 
        port 22 
        protocol-version v2 
    } 
} 
system { 
    host-name Vinz-Clortho 
    login { 
        user vyatta { 
            authentication { 
                encrypted-password **************** 
            } 
            level admin 
        } 
    } 
    ntp-server 0.vyatta.pool.ntp.org 
    package { 
        auto-sync 1 
        repository community { 
            components main 
            distribution stable 
            password **************** 
            url http://packages.vyatta.com/vyatta 
            username "" 
        } 
    } 
    syslog { 
        global { 
            facility all { 
                level notice 
            } 
            facility protocols { 
                level debug 
            } 
        } 
    } 
    time-zone US/Pacific 
} 
share|improve this question
    
Have you tried using static IP's for the Vyatta appliance? Also it's been a while since I used Vyatta but I'm almost certain I had to define routes between the interfaces to get it to work. –  Helvick Dec 19 '10 at 20:21
    
Yea. I tried setting statics on all the interfaces including the bridge, as well as different combinations of with and without. I haven't done anything with routes though. The way I understand it, a bridge looks invisible to the hosts on either side. I appreciate you taking the time to help! –  Daedalus Dec 19 '10 at 21:18

1 Answer 1

up vote 0 down vote accepted

No Go. Turns out this is not yet possible. From the vyatta forums:

In general linux does not support bridging wireless in station mode. The problem is that wireless is internally point-to-point based and doing bridging requires MAC address spoofing.

share|improve this answer
    
This is possible if you are using something like dd-wrt. –  Jason Axelson Mar 24 '11 at 0:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.