Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

No matter which VNC viewer I use when I type in something that contains the letter d, the current window will be minimised. This doesn't happen when am typing direct on the server I'm vnc-ing to.

share|improve this question

I had the same issue. It's related to the global key bindings. The key binding "Hide all normal windows and set focus to the desktop" under System -> Preferences -> Keyboard Shortcuts shows as "d" on the host and as "D" on the remote desktop. I changed it to something else (eg. disabled) and my problems were solved.

share|improve this answer
Perfect!! Thank you very much, I had this same problem. For slight clarification, the pesky default item is under System -> Preferences -> Keyboard Shortcuts -> Window Managment -> "Hide all normal windows and set focus to the desktop". I reset it to CTRL + Shift + ~ – Brian Mar 31 '11 at 8:20

Do you have a command character pressed, like Ctrl, Alt, or Win? Sometimes when closing VNC with a keystroke I've had a command key pressed, so that the unpressed event doesn't get sent to VNC before it closes. From then on the command key acts pressed until you hit it again, basically unsticking it.

share|improve this answer
no it doesn't allow m to type the letter d. I have to press alt d to get the letter d to appear. I've tried rebooting the server then pressing nothing but d and it still happens. When I press windows key then d the same thing happens so I assume windows key is stuck – user20338 Dec 18 '10 at 23:30
tried remapping the windows key but didn't fix – user20338 Dec 18 '10 at 23:42

So I have seen the same question asked on 5 different stackexchange sites, and all the answers say to just remove the hotkey, which does work, but isn't the root of the problem (at least it wasn't for me). The real problem is that the windows super key is not mapped correctly, as is described here:

i3 ignores mod4 (windows key) when in VNC session

Basically just run these two commands

xmodmap -e "clear mod4"
xmodmap -e "add Mod4 = Super_L"

That should do it. Now the desktop should only be shown if you hold down the super (windows) key as well. The "d" key (and other keys with super shortcuts) should now work as expected.

You may need to replace Super_L with something else depending on your keyboard, check the link above for details.

share|improve this answer

Also you can use openbox as window manager instead of metacity for VNC sessions. Metacity shortcuts will not work, and Mod4+D does not break anything.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.