Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi, Apache with php works well, but none of the changes I make in php.ini have effect, I've even delete all the contents of the file, then restart Apache, and run phpinfo() and surprisingly everything continues working well.

The file I'm editing is the one that appears in the phpinfo() like "Loaded Configuration File". (/etc/php5/apache2/php.ini)

P.S. I'm running Ubuntu 9.04 and PHP 5.2

More Details:

I'm restarting with sudo /etc/init.d/apache2 restart, I've also tried sudo /etc/init.d/apache2 stop, and then start, at restarting I get:

  • Restarting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName [ OK ]

"which php" did not produce any results.

My installation of PHP was done using Synaptic Package Manager, choosing "Mark Packages by task" and then LAMP server.

I don't have any clue of what to do...

share|improve this question
    
Didn't know that if could run without a php.ini. Thanks a lot to all of you. –  MrAn3 Jun 6 '09 at 23:08
    
for that error, make sure that the hostname is set correctly –  Jimsmithkka Jan 5 '11 at 10:01
    
I am facing the same problem. You seem to have solved yours using the responses of this thread but... I am not sure how. Could you elaborate a bit more on what did the trick for you? Thank you in advance for your help. –  Euloiix Sep 3 '12 at 18:56
add comment

10 Answers

Looks like you are changing the wrong php.ini - Check the location of php.ini that is given in the phpinfo() output! This will show you the php.ini that is actually used.

Also check if the Apache restart really succeeded. ;)

share|improve this answer
    
The above answer is right, wenn you have installed the libapache2-mod-php5filter module, the php.ini of this file is the right file to modify, changes on the normal php.ini file will do nothing. (i had the same problem installing moodle and mahara on one system, moodle needs this package!). –  user168566 Apr 8 '13 at 16:41
add comment

Make sure you're editing the correct file. There are several files for different circumstances all (at least on Jaunty) nestled in /etc/php5/

For apache+mod_php, you want /etc/php5/apache2/php.ini

share|improve this answer
add comment

It continues to work because PHP will run without a php.ini file, but it runs with whatever options were turned on at compile time.

What changes are you making that are not showing up in the phpinfo() output?

share|improve this answer
    
+1 Excellent! Long searched for this! –  Marco Demaio Jul 6 '11 at 16:34
add comment

I am using Ubuntu 10.04 (lucid). In order for changes on the php.ini to work, you must reboot the system. Restarting apache is not enough.

share|improve this answer
add comment

Try

sudo aptitude install libapache2-mod-php5filter 

than using config in /etc/php5/apache2filter/php.ini instead

share|improve this answer
add comment

I had the same problem, and for those answering before me, NO I'm not editing the wrong file.

I'm running Ubuntu 10.04 running Nginx and my PHP install uses PHP-FPM. PHP-FPM seems to be what causes the problem.

To solve the problem, I run php-fpm from the command-line. (Just type in php-fpm and hit enter.)

In my case, this gives me a few warnings about modules not found, and then exits.

After this, phpinfo shows the correct values, without restarting the webserver.

I hope this helps.

share|improve this answer
add comment

I've had the same problem with an earlier version of Ubuntu (12.04), Apache 2.2.22 and php5-fpm fastCGI flavour of PHP. Doing

service apache2 restart 

isn't enough, because it just restarts the http server: you have to issue also the command

service php5-fpm restart

to have the application server restarted and PHP read the php.ini file again.

share|improve this answer
    
did it for me! thanks –  ACarter May 27 '13 at 9:05
    
@ACarter no problem, just wanted to add my personal contribute to the KB :) –  Paolo Stefan May 27 '13 at 9:48
add comment

Open up the terminal and type

which php

Then you'll know which version you have and you can go from there. I would also be checking to see that you did properly restart your apache server

share|improve this answer
add comment

Verify that you are not using 2 php.ini files - one for the web server module and another one for the CLI version.

share|improve this answer
add comment

In config.php change ServerName="127.0.1.1" to

ServerName="Localhost"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.