Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to upgrade Ubuntu from Hardy to Intrepid last night, and seem to have killed it.

I can boot into "recovery mode" and the root shell, but it freezes when it tries to start the Gnome environment etc.

In this recovery mode it doesn't seem to be on the network (ie. ifconfig shows the lo bit but not the eth0 bit) And I can't ping or ssh to it.

How can I start networking from this prompt?

cheers

phil

share|improve this question
add comment

3 Answers

up vote 8 down vote accepted

Do you normally get your IP address from DHCP server ?

$ ifconfig eth0 up

$ sudo dhclient eth0

To set IP address you want (for example 192.168.0.1) type:

EDIT:

ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
route add default gw GATEWAY-IP eth0

If you have a problem with gdm during the boot, switch to the real console:
Use the Ctrl-Alt-F1 shortcut keys to switch to the first console.
To switch back to Desktop mode (gdm), use the Ctrl-Alt-F7 shortcut keys.

share|improve this answer
    
Don't forget to add your default gateway (if you want internet access): route add default gw <gateway-ip> –  Matt Simmons Jun 7 '09 at 15:31
    
Matt: True, thanks. –  onesysadmin Jun 7 '09 at 15:52
    
thanks, this was exactly what I needed –  interstar Jun 7 '09 at 17:49
    
+1 Still works on 12.04. PS: you don't need sudo in recovery mode. –  l0b0 Feb 1 '13 at 20:16
add comment

To start networking, /etc/init.d/networking start should do the trick. I'd say that if Gnome isn't starting, you've got X config problems. If you disable gdm from starting on boot, then you should be able to get to a regular console prompt and do diagnosis from there (check /var/log/Xorg.0.log and so on).

share|improve this answer
add comment

I wrote this network troubleshooting guide a while ago and should help you find out what the problem is. It should take you from checking your network driver to making sure your IP configuration is correct.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.