Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a server with Plesk installed I have added a CNAME rule pointing from one of the sites subdomains to an external website.

I have checked the named configuration for that domain name and it shows the CNAME however the sub domain just points to the default server page and ignores the CNAME rule. Named has been restarted and I've also run the rvmng reconfigure-vhost command.

I edited another server to test this, on cPanel, and it works fine.

The conf file for the domain:

; *** Ts file is automatically generated by Plesk ***
$TTL    86400

@       IN      SOA (
                    1292946742      ; Serial
                    10800   ; Refresh
                    3600    ; Retry
                    604800  ; Expire
                    10800 ) ; Minimum             IN NS          IN A             IN A             IN A                IN A                IN A                 IN CNAME                 IN CNAME               IN CNAME             IN MX  10

You can see the CNAME rule in the file but it just gets ignored?

Thanks in advance for any help.

EDIT: I just noticed that the site's nameservers aren't on this server but the default doteasy ones so I assume that may be why the rule is ignored. I will change the nameservers and see if that solves it. I'll update here with the outcome. Thanks guys for your tips so far.

EDIT 2: The server only has one IP address so it won't be possible to use custom name servers. Could this be the cause though? When I run dig cname it returns:

; <<>> DiG 9.7.1-P2 <<>> cname
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20919
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;     IN  CNAME

;; AUTHORITY SECTION:        3600    IN  SOA     2010070101 3600 1800 86400 10800

;; Query time: 258 msec
;; WHEN: Tue Dec 21 20:37:22 2010
;; MSG SIZE  rcvd: 95

I take it this is why the CNAME is being ignored? As the DNS isn't actually hosted on our server?

UPDATE The issue was solved, offsite DNS was why the rules were ignored. Thank you all for your help.

share|improve this question
up vote 1 down vote accepted

did you try using dig ?

dig cname 

I understood that dig would give an answer if something is configured in the ANSWER SECTION

EDIT Instead of the CNAME, I think it should be an A record than a CNAME record.

For example: Look at how to redirect your domain name to Tumblr and have them host your blog . I am assuming you are trying to do the same here

share|improve this answer
Thanks, I think this helped towards finding the problem. – Ben Dec 21 '10 at 20:03
(And please add the response of that to your question.) – Erik Dec 21 '10 at 20:19

If you are receiving the right records from your Plesk server (see dig command below), then it's a cache issue (old records have been cached by your PC/ISP's nameservers):

# ask A records from Plesk server
# you should see CNAME record in the ANSWER section
dig @plesk.server

# or just directly ask for CNAME record
dig @plesk.server cname
share|improve this answer

Why do not you use A records? It is the same zone file, in this case it is much easier (and you can avoid future troubles).

The zone file looks ok btw. You should look with standard tools (like host, dig) to check that it is indeed serving what you see in the file. It also can be that a resolver dns server cached a negative response earier (if you just put these records there).

Tell us the real dns name if you really want a fix!

EDIT: Sorry I entirely overlooked that you have in your records.

On the other hand you are looking at the wrong direction. But I do not bother until you tell your real domain name.

share|improve this answer
A records can only contain IP addresses but I need to point to – Ben Dec 21 '10 at 19:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.