Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Greetings!

We're using OpenVPN and today hit an unexpected connection limit of 60 - even though max-clients is set to the source code default 1024.

Server log:

Tue Dec 21 13:49:41 2010 MULTI: new incoming connection would exceed maximum number of clients (60)

We're slowly adding new clients to the VPN and expect to hit 200 some time next year, if we can get it working.

We're running the server on a Win2003 R2. OpenVPN 2.0.9 Server config as follows:

local 192.168.10.211
port 1195
proto tcp
dev tun
dev-node OpenVPN_Vision
ca vision_ca.crt
cert vision_server.crt
key vision_server.key # This file should be kept secret
dh vision_dh1024.pem
server 192.168.211.0 255.255.255.0
ifconfig-pool-persist vision_ipp.txt
;server-bridge 10.8.0.4 255.255.255.0 10.8.0.50 10.8.0.100
;client-to-client
keepalive 10 120
comp-lzo
;max-clients 100 # Default in source code is 1024
persist-key
persist-tun
status openvpn-status-vision.log
log vision.log
verb 3

I would greatly appreciate any help or input on this one. Thanks! Best regards, Robin

share|improve this question

2 Answers 2

up vote 3 down vote accepted

This seems to be your problem: https://forums.openvpn.net/topic2445.html

(quote)"It looks like the 2000 max_clients setting is getting overridden in we_init and getting set to WSA_MAXIMUM_WAIT_EVENTS, which is 64, minus 4. My understanding is this is a hardcoded limit built into the windows kernel. The 60 client limit is determined by subtracting extra_events (set to BASE_N_EVENTS, or 4) from it."

Basically, run it in udp mode and you can go over 60. The limit is in windows and openvpn isn't to blame.

share|improve this answer
    
Sirex, I'm not blaming anyone. Well, perhaps Windows. ;-) Your answer is not really satisfying, but still seems to be the way to go. Thank you! –  Robin Dec 21 '10 at 15:20
    
Yea, it's not ideal, but the limit is hard coded into windows :-( –  Sirex Dec 21 '10 at 15:33

Are you running it through any type of router/firewall? That could have it's own limit.

share|improve this answer
    
Good point! Well, I already eliminated those as possible reasons, but I should have said that in my question. Thanks! –  Robin Dec 21 '10 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.