Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having issues with my "Public Folders" mail enabled folders receiving e-mails from external senders.

The folder is setup with three Accepted Domains (names changed for privacy reasons):

1 - domain1.com (primary & Authoritative) 2 - domain2.com (Authoritative) 3 - domain3.com (Authoritative)

When someone attempts to send an e-mail to folder@domain3.com from inside the organization, the e-mail is received and placed in the appropriate folder. However, when someone tries to send an e-mail from outside the organization (such as a gmail account), the following error message is received:

"Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 Recipient address rejected: User unknown (state 14)."

When I try to send an e-mail to the same folder, using the same e-mail address above (folder@domain3.com), but with domain2.com instead of domain3.com, it works as intended (both internal & external).

I have checked, double checked, and triple checked my DNS settings comparing those from domain2 & domain3 with them both appearing identical.

I have tried recreating the folders in question with the same results.

I have also ran Get-PublicFolderClientPermission "\Web Programs\folder" with the following results for user anonymous:

RunspaceId : 5ff99653-a8c3-4619-8eeb-abc723dc908b Identity : \Web Programs\folder User : Anonymous AccessRights : {CreateItems}

Domain2.com & Domain3.com are duplicates of each other, but only domain2.com works as intended. All other exchange functions are functioning properly.

If anyone out there has any suggestions, I would love to hear them. I've just hit a brick wall.

share|improve this question
add comment

1 Answer

Turned out it was a setting buried in our spam filter. Problem resolved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.