Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As part of some performance troubleshooting, I've monitored the slow startup of a "cold" App Pool (one without an active worker process) in IIS.

When using a built-in account, the App Pool starts in sub-second time. When using a custom local account the App Pool takes 30+ seconds to start processing requests.

The service appears to be making requests to wpad.mydomain.com, an address it does not have access to, which causes it to wait 30 seconds for a response before eventually timing out. As a workaround, I've added the hostname to the server's hosts file, to direct the traffic to the local machine, which returns much faster (1-2 seconds).

What do I need to do to stop IIS making this request when this identity is used for the App Pool?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Disable web proxy automatic detection.

share|improve this answer
2  
To clarify, you need to disable automatic proxy detection for that app pool user account, so you will need to login as that user and disable it under internet options->connections. –  Dan Dec 21 '10 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.