Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently learned of the joys of square brackets with SMART_HOST to have sendmail ignore MX lookups. I need this functionality, however, I can't seem to make it persistant. Sending mail with -Am works, however, -bm does not. In the -Am case, the correct mail server is used. In the -bm case, an MX lookup is still being performed. Is there a way to disable MX lookups (or some working alternative)?

Thanks

share|improve this question

1 Answer 1

You can use Sendmail's mailertables feature to override MX records on a per domain basis.

http://www.sendmail.org/m4/mailertables.html

share|improve this answer
    
didn't work. I tried doing ".bar.com smtp:[foo.bar.com]" (and numerous variations of) without luck. It still went to mx.bar.com –  daniel Dec 22 '10 at 21:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.